6 track recorder freeze!

@odevices The problem I’m seeing with this “freeze” issue is different on my ER-301, I can’t save the stereo pair. I can save a mono channel, but not stereo. So I tried this on v0.2.27 and I’m having the same issue.

If I record a stereo pair on In1 and In2 the ER-301 creates tmp-1.wav and tmp-2.wav files that are the correct size, but were not saved and are not savable to a proper file name.

As I can’t save I try ejecting the card to see what’s what, but I get a lower display window message “In use, Do NOT Remove.”

I remove it anyway, rename the tmp-1 and tmp-2 file.

At this point after reinserting the SD card the ER-301 doesn’t recognize the card anymore and I have to reboot.

The two renamed files work.

1 Like

Another unwanted behavior is that when recording a stereo pair on the latest firmware using In1 and In2 I’m getting some distortion noise randomly in the recording that lasts a second or two.

It’s a kind of dropout and it consistently happens in each recording though at different places.

If I record the same bit of audio from In1 as a mono recording the file is perfectly clean.

reporting back, it happened again… thanks

Can you confirm if it’s only happening with a stereo recording or is it happening for a mono recording too?

mono here…

…and this time erasing the temp files doesn’t fix it…it seems that
the 46th sec is the critical one same as @phonk
Also it’s a freeze @odevices ( checked it for about 2 mins)…

I just successfully recorded for 30mins so this is going to require more forensics to figure out.

In the meantime, everyone who has gotten the recording freeze: Using your PC, please verify and repair your SD card.


  • Disk Utilties > First Aid > Verify Disk
  • Disk Utilties > First Aid > Repair Disk


  • Computer > Right-Click on SD card drive > Properties > Tools > Check Now…

If the freeze happens again after the repair, please report here with as much detail as possible. I’ll be trying various things over here too.

Card checked out perfect.

Mine doesn’t freeze, I just cannot save the recording when I’ve got a pair being recorded.

Once I’ve gotten into this “loop” where I can’t save, discarding the audio or switching back to mono doesn’t work. I have to reboot.

Back in mono mode I can record using the 6 track and I get the dialog after hitting save for New File.

Confirmation please: A stereo pair on IN1 and IN2 should only create one (stereo) file. Perhaps you are recording 2 mono tracks?

I get that but on the card it’s showing two tmp.wav files.

My question is a confirmation of what you are doing so I can replicate it. :sweat_smile: Not trying to tell you that you did something wrong. The 2nd wave file could have been from a previous recording.

What else is going on in your ER-301?

Admin menu:
Channel setup
Then press 2X stereo
Press up button
Press six track recorder
Display shows six tracks
Press M1. Press M1 a second time. Choose In1
Press M2. Press M1. Press M3 to choose In2
The first two tracks are showing In1 and In2
I press record
—cannot save files/file.

If I remove the card against your prompt not to do that, there are two tmp.wav files on the card. If I rename them they are the two sides I recorded - as two mono files.

So this indicates you are recording 2 mono tracks. (FYI, if you place the cursor between the 2 tracks and press ENTER to link then you get a stereo track and single file).

When you say you cannot save a file, what actually happens when you press Save Audio? I’m asking because I am as of yet unable to replicate any of this. :thinking:

Time to get sheepish at the mistake of not linking the mono tracks. This also allows the stereo file to be saved.

I thought my setting things up as stereo, that was enough.

I should be equally sheepish for creating the interface!

Still, you should be able to save the files for 2 mono tracks. Can you describe what happens that makes you think that you cannot? I’ll add here that since you are saving multiple files in this case, the interface requires you to select a folder as a destination or create one.

I’ve created a folder multiple times, but I still do not get the prompt to enter file names. I described my process two comments from me ago. Don’t know what else to add.

I need detail on the part between Stop and ‘–cannot save files/file’. So I will go the other way:

  • Press Stop
  • Press ‘Save Audio’
  • Scroll with the knob to select a destination folder.
  • Press ENTER to choose the folder.

At this point, the 2 mono tracks are saved to that folder. Suppose the folder was named XYZ, then the two files will be called

  • XYZ-T1.wav
  • XYZ-T2.wav.

If files of those names already existed in the XYZ folder then the files will be called

  • XYZ-takeN-T1.wav
  • XYZ-takeN-T2.wav

Reading your last note, “Scroll with the knob to select a destination folder” - I never did that, I only used the forward and back buttons.

Now that I’ve scrolled the knob it saves every time in the chosen directory on a second push of Enter.

I rebooted and it’s still working correctly.

hmmmm, seems to be pure user error in that I was trying to save IN the directory instead of selecting the directory.

Bummed for wasting your time.

Totally not a waste. I got good feedback about the recorder interface with this interaction!