Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

A few small bugs (OS V4.17 and earlier?)

Hi, just a few little things to report. I am using the latest OS (v4.17) but not 100% sure if these things are applicable to this version or to earlier versions.

  1. The preamp settings don’t seem to work. I am sure they were fine in v4.08 and earlier versions but the soft buttons S1~S3 now don’t select anything on the display (it used to highlight the setting) and the volume of the audio coming in doesn’t get changed at all.

  2. When selecting a modulator for anything using S1, and when in the main source selection screen with all the inputs is shown, if you use a constant voltage source (an offset, slider, tetrapad fader, etc. etc.) in any of the inputs A~D then it won’t be displayed properly in the little VU meters. It only displays the level when you move the control then drops to nothing when the control is stopped being moved.
    If, however you focus into one of the input groups then constant voltages are displayed as you would expect - with a moving line showing the voltage that stays in place. I hope that makes sense!
    I am sure this has been an issue for a while, at least to mid version 3 which is when I got my module.

  3. When trying to save a custom unit using the slash symbol “/” in the file name then it refused to save. I tried a file name that had “V/O” at the end and it said “cannot save O.” - not sure about any other special characters, but once I got rid of the slash it saved fine. I can’t confirm which OS version as I’ve only just started with custom units really.

If you need any more info give me a shout.
All the best, the module keeps getting better and better and still loving it!

Cheers,
Ian.

2 Likes

thanks for sharing your observations! please, could you also state them over in the firmware thread? also, which firmware are you exactly using, i.e. KHz-wise…?

or: @odevices, i feel that these informations are better served in the goofing-off-hard-thread.
what do you think about moving @ianski’s post to there?

Hi,

48Khz version.

I was going to post in the 4x thread but as mentioned I can’t guarantee these issues affect only the latest OS.

The preamp settings not working however is definitely a 4x thing, I am sure I’ve changed settings in the last version I was using which was 4.08

Cheers.

I spent some time with the 301 last night and can confirm the preamp settings do in fact work perfectly. Not sure if I had a temporary snag before but I think I might have been fooled that is wasn’t switching settings, perhaps because of the way this used to be shown above the “S” buttons.

The other 2 small issues still remain but aren’t very imprtant of course.

  1. I’ll try to make it more obvious. FYI, there is the 1x, 2x, 4x indicator in the main display.
  2. This is by design. The meters are showing loudness and thus ignore DC. A signal that doesn’t change is silent (i.e. 0dB).
  3. The slash symbol is reserved as a path separator and can not be allowed for use in naming files. In fact, I remove any forbidden characters from the keyboard when asking the user for a filename, or so I thought. Do you remember where this occurred?

Seriously don’t worry about the preamp stuff it works fine and doesn’t really need any adjustment, I noticed the 1x,2x,4x last night when checking it again.

I had a feeling the meters ignored DC and that was why the value dropped to zero. I just found it odd that the small meters worked differently from the modulation input display. Not a biggie.

I’ll confirm exactly where the slash symbol came up, I’m not at home atm so might be a delay of a day or two. I’m pretty sure it was as I was saving the unit rather than the renaming procedure itself.

Thanks for the reply, all the best.

1 Like