Can't get the teletype -> ER-301 to work (FIXED)

Hi all, I’m trying to get my teletype and er-301 to talk to each other with no luck. Here is what I did:

Running latest version of ER-301 (0.4) but also tried a 0.3 one.
Running Teletype 3.0

Soldered as described (not as cleaned as I wished, will fix later):
59%20PM

Connected the modules as described:


Created a simple sampler module that requires a gate, to which I try to use the teletype on port 1:


Simple command on the teletype to trigger port 1 (put it in the metronome script, which is running, but nothing happens on the er-301…):

Any idea what I could be doing wrong? I can get the teletype to work with Just friends, same cables.

Thanks!!

Maybe you didn’t enable the Teletype-integration in the ER-301 firmware? Go into Admin -> System Settings and scroll all the way down to find the Monome Teletype settings. You should set Enable Teletype control to “enable” and the I2C slave address should be set to 0xB1 (edit: apparently it has to be 0x31. 0xB1 works for me, weirdly enough).

If that wasn’t the problem, I’d fix the soldering now instead of later. It might very well be the culprit. Nearly everyone (including me) who had problems that weren’t obvious mistakes on the software side fixed them by fixing the soldering. There’s not much to get wrong apart from that.

Thanks.

Forgot to mention I enabled the teletype on the 301 as you described.

I tried again to clean the soldering, also checked with a multimeter, seems to be fine…

I guess I will triple check

Fixed! Address has to be 0x31…

1 Like

Thanks! I was experiencing the same issue. That fixed it for me.

Hi there, trying to get back to my ER-301 after years…
Upgraded to 0.6, hooked up my TT, but there is no such thing as a “Monome Teletype” tab in the Admin > System Settings section as descreibed here : ER-301/Teletype Integration - O|D Wiki

the old wiki’s not up to date for that matter
(@odevices: might be helpful to put a link to the new docs on the old wiki?),
you’ll find the corresponding new steps (it’s a package now) in the new docs:

Many thanks !