Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Changing duration/step length as part of a group

support

#1

I created a sequence where I have patterns that have either 96 or 108 pulses at 24 PPQN, so patterns that have 8 or 9 eighth notes. For the patterns that have 9 eighth notes, I created a group on the 102 that includes one eighth note (12 pulses) such that when the X gate is high the duration and step length have at least 12 subtracted so that that step and duration are 0 so all of the patterns now have 8 eighth notes. What I’ve noticed is that even with a duration and step length of zero, it appears that a “skipped” step will still take one pulse before going to the next step. The easiest way to explain it is to show a video: https://www.youtube.com/watch?v=WBytTgjWQbA

I put a drum sound every 6 pulses and have only one pattern looping. When it starts the drum is in sync. When I raise the gate on X and subtract 12 from the step, you can hear how the drum becomes out of sync with the pattern. After 6 loops, the pattern is back in sync. (Then I lowered the gate and added the step back in.)

Is this expected behavior? I wouldn’t be surprised if it is because I realize the 102 probably has to process that the gate is high and make the subtraction. I just want to bring it to attention in case it is unexpected. In any event, there are work arounds like either creating a second group that subtracts one from the preceding step or taking 6 off of two different steps.


#2

That is not expected behavior. Zero length steps should be skipped so that would be a bug in my opinion. May I ask you to repeat your experiment but instead of subtracting “at least” 12, could you try multiplying the DURATION by zero?


#3

Probably not record time, but that was fast :slight_smile:

I just realized what I was calling step length should be gate length, but I think the nature of the issue is still apparent.

It does the same thing when the duration is multiplied by zero. (I also reset the adding behavior so it was only multiplying.) Additionally, with duration multiplied by zero, but gate still non-zero, it appears that my envelopes are still firing. When I changed the gate length to also be multiplied by zero, the additional clock cycles are still present, but my envelopes aren’t firing anymore. I think I was seeing this same behavior when subtracting from the gate length, but failed to mention it in the previous post. I can get you another video if need be.

EDIT: Also, I’m running 2.09 on the 101 and 2.19 on the 102.


#4

So, I’ve confirmed this behavior and added it to the issue tracker. I’ll have it fixed in the next ER-102 firmware release (i.e. v2.22).

Sorry for the inconvenience! :bowing_man:

In the meantime, perhaps you can work around the issue by doing the opposite transform?
In other words, have the steps originally set to zero duration and use the LOW group transform to add 12.

Oh wait. That won’t work either because the step will get skipped before the group transform gets a chance.


#5

No worries. Will keep an eye out for the update.

It was a nice exercise figuring out how to get around it. I did consider the “opposite” solution, but as I was transposing from something else I had written before, I attacked it by subtraction. Funny how it works. I actually found subtracting 6 from two different steps that have a length of 12 adds some nice rhythmic variation, so, I’d say it worked out! :smile:


#6

The musical workaround definitely wins against the technical workaround any day! Good one :wink:


#7

I think i have noticed in the current firmware it won’t skip steps completely if they have a trigger/gate on them. Is this the same issue?


#8

I’m not aware of your issue and I am unable to reproduce it. Do you have any other details?


#9

I’ll do some experimenting and report back.


#10

Two separate issues:
@odevices
1st one:

Ok if a duration of a step is 1, using group modifier on that step to make the duration zero doesn’t seem to work, in other words you can’t use a group modifier to skip a step.

The gate trigger doesn’t make a difference but I had thought it did.


#11

@odevices
Issue 2:
Another slightly odd thing. A pattern of one step with a duration of zero but a gate of one will trigger as if the duration is also one.

I think the issue is the first step has to have a duration in this scenario this is probably unrelated to the other group modifier issue I mentioned earlier.

Another way to see this is make a new pattern with two steps and patch the cva to an audio out. Set the multiplier high and both durations to zero and the cva values to different numbers and enable smooth. Changing the duration of step one between zero and one has no effect but changing step two between zero and one does. The first step must have a duration, I think that is what is happening.