Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Clicks...cpu 66%

support

#1

so i’m preparing for a concert and have for the first time a rather big and complex er301 setup, with internal mixing of external signals, sample playback, eq etc.
but only just now i realized that i have occasional short digital clicks when i rehearse.

i’m not sure, but i think i do hear these tiny spikes in the critical load window, cpu is at 66%.
is this normal? i’m using the latest firmware 48kHz.


#2

Today i got some auditive hickups when modulating the time on the pitch shifting delay, i could see them spiking on the cpu load meter but was running with only about 20% workload. So i guess in my case this is not correlating with the overall cpu performance.


#3

@kilchhofer and @elias, the diagnosis would be greatly assisted by a recording of these short digital clicks.


#4

here is a wav file:

and here you see it:

btw i think it’s getting worse, i never had this much clicks and in such short intervals. yesterday i thought they pop up when i have alot of cv going in and modulating it extensively, but this recording now has no cv other than trigger, v/oct and mixing…


#5

btw bypass isn’t a true bypass right? i don’t see the cpu drop when i bypass elements.
it would be a great help if i could somehow bypass a whole chain to reduce cpu.


#6

Unit bypassing is implemented like this:

The purpose is to keep feeding the bypassed units their inputs so that when you re-engage them they are primed and ready to go. Imagine bypassing and then re-engaging a delay line.

That was the original intent anyway. This request for CPU-efficient bypass has come up a few times now (and is actually much easier to implement!), so maybe I should just convert it to this?


#7

By the way are using a Clocked Delay in this patch? The glitches are suspiciously regular (as in they are usually fixed amount of time after a transient)…

The reason why I bring this up is that the Clocked Delay has a bug in it which is causing it to act erratically to some clock sources.


#8

ja, i use the clocked delay and i first thought oh it’s the clock glitches again, but i feed it a tap tempo unit internally and the spikes remain even when i disable the delay unit.
so the bypass isn’t an actual bypass but some sort of mute of the signal? i just bypassed every unit in my chain and the cpu stays the same. for me in this moment i would prefer a true bypass but i totally see the advantaged of your idea, especially for the effects, so maybe a admin setting where one can choose between the two approaches?


#9

ok sorry i hadn’t tested without the clocked delay unit but just bypassed it. the spikes are gone after deleting the clocked delay!! so i think this unit makes problems even with an internal clock…?
anyway, very happy if it’s really just this delay!


#10

Could we have it both ways, maybe via a setting in the admin area? :smiley_cat:


#11

Done!


Request: Make Bypass modulatable
#12

Were you modulating the num or div parameters of the Clocked Delay by any chance?


#13

That’s great! I think the CPU bypass method is more desirable when designing a complicated patch and trying to figure out if any units can be eliminated. The other type of bypass is more desirable after a patch is completed and you’re ‘playing’ the patch.


#14

@kilchhofer, it would be great if you could kindly try your patch (with the Clocked Delays included) on v0.2.14 and see if the pops have gone away. :bow:


#15

I’m probably too late to the bypass party … but… I’m sure there’s instances where you’d want true CPU bypass and others where you’d want the signal bypassed (such as when auditioning different types of CV processing) instead of being an overall broad stroke setting.

What if when the bypass option is on the smaller screen you had 2 options instead of 1:

Currently: S1 toggles signal bypass on/off

Idea: S1 toggles signal bypass on/off, Shift + S1 toggles true processing bypass on/off

I guess there’d need to be a visual indicator to show the difference… but I thought I’d throw it out there!


#16

That could work (un)favourably either way depending on a host of other things…

I am also a bit late, but yes - another +1 for both from me :slight_smile:

‘both’ … a Eurorack addicts favourite mantra!


#17

amazing service, honestly brian, you’re incredible! :grinning:

no, no modulation whatsoever.

i will test everything tomorrow. i had rehearsal this afternoon and played with the variable delay instead of the clocked delay, after maybe two hours clicks were suddenly audible, sounded like an old record, it kinda looped…very strange, i recorded it, will upload tomorrow.


#18

Hi Neil, I agree with this too - certainly from a performance perspective some things you want to continue processing whilst bypassed & other things you don’t care


#19

so here’s the recording of yesterday, without the clocked delay, i’m not sure what it is, it really sounds like vinyl crackle:


#20

it workes without hickups now, this and the true bypass seems to work great!
thanks brian