Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Clicks when recording

I’m getting clicks inputting sound into the module when running 0.4.11 48 khz and also 0.4.11 low latency version. Very basic setup with just a sound source being inserted into the module and then being output again. When running 0.4.09 there is no clicking (same simpel setup).

Is it repeatable? If so, next it happens can you check the CPU load please?

Yes it is - constant, but kind of random sounding. I Tried putting a sine from another module into it this morning, and i get the clicks when the sound source is inserted but not when i only insert a sound source with silence. CPU load 4%.

Which physical input are you connecting to with the source coming from outside the er301?

I connect it to input “in” 1 of the Er-301

That seems right…

Hey Brian, any comments on this ? Cheers.

I’m at a loss as to what it could be so let’s gather more data.

So far I understand that when you connect a sine from an external VCO to IN1 and select it as the source for OUT1, you get “clicks” when listening to OUT1 for v0.4.11 but not v0.3.25 (both 48kHz, normal latency). No quicksaves are in use. Nothing else is going on in the ER-301.

May I have a recording of the clicks and input signal? Use the internal 6-track recorder and record 30s simultaneously OUT1, IN1, and IN2 (connect OUT1 to IN2 with a cable). This should yield 3 WAV files. Please post and drop them here.

I was not able to upload a file of that size here, but here is a download link:

Recorded in the order you suggested.

Hmm. There are no clicks though. Did you hear clicks when you were recording?

There are clicks all over :smiley: Have you listened with headphones ?

Ah now I hear and see them. I was expecting something more obvious.

Are you sure this is the normal latency firmware and not the low latency firmware? On a hunch, I tried the low latency firmware and I can reproduce the clicks but not in the normal latency firmware.

My bad, it was in fact the low latency version. With the cpu this low (4%) there shouldn’t be clicks though, right ?

When changing to normal version i don’t get clicks now as oppose to last time i tried 18 days ago.

I can definitely believe that the low latency version could have problems like this. It is still quite experimental. However, nothing has changed in the normal latency version in the input digitization code since v0.3, so I suspect that you have only heard these clicks in the low latency firmware.

So lets tentatively conclude that this is a problem only with the low latency firmware, but let me know if it ever comes up in the normal latency firmware.

Sure thing I will :+1: Will these issues in the low latency version be improved with the new update ?

Maybe not the next update but hopefully soon after that depending on how difficult it is to fix.