Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Custom Control problem


#1

I made a Clock Sync LFO and want to create Custom Controls for the MULT and the DIV parameters of the “Pulse to Hertz” unit.

Mult goes from 1 to 32, so I want the MULT Custom Control to do the same:

  • In the “Pulse to Hertz” unit I set GAIN and BIAS to 1.
  • I create a Custom Gain/Bias Control, name it MULT and set its BIAS MIN to 1 and BIAS MAX to 32.
  • But now a MULT setting of 1 is effectively 2, because the BIAS values of the original MULT fader and the MULT Custom Control are added. (?)
  • So I go back to the original MULT fader in “Pulse to Hertz” and set the BIAS to 0. Now it sounds right (like 1), but as soon as I move the fader up and back down it snaps back to 1 and doesn’t go deeper (and it sounds like MULT 2 again).

Am I doing something wrong or is this a bug?

In cases like this @NeilParfitt’s Custom Unit Control alias Idea would be so helpful!


#2

Which fader are you moving here? The custom control or the one on the Pulse To Hertz unit?

Your latter setup (Pulse to Hertz gain = 1, bias = 0) sounds correct to me. Can you post a saved copy of your unit?


#3

It happens with both faders, but setting the MIN of the Custom Control fader to 0 is not really an option because I want it to go from 1 to 32.

Attached you’ll find a Chain Preset: Channels 1 and 2 are only to monitor what’s going on (Ch 1 is a Sine OSC, pitch modulated by the Clock LFO, Ch 2 is the Clock pulse triggering a VCA).
Channel 3 ist the Clock LFO with a GATE input (connected to Input G1).

You hear that the LFO frequency is twice as high as the Gate frequency. If you go to the “Pulse to Herz” unit and set the MULT Bias to 0 it works (LFO frequ. = Gate frequ.). But as soon as you move this MULT fader up and down, it snaps back to 1.

Thanks for taking a look!

Clock LFO.chain (16.2 KB)


#4

OK, I think I get it. I’m not sure why you’d move the mult control on the Pulse To Hertz unit after rigging it up to be controlled by the fader on the top level of the unit?

But I think the reason that it’s snapping back to 1 when you move it is because that control’s definition has it set to a min value of 1.

The good news is that you can edit that control’s definition, very similar to the way you’ve added a mult control to the top level mixer unit. Just focus press the header menu on the Pulse To Hertz unit, edit controls, choose the mult GainBias control, change it’s min value from 1 to 0 and press enter to save the control change.


#5

Thanks a lot, that helps!

I moved the original MULT fader because I didn’t know how to achieve what I had in mind, so I was just exploring different settings.

True, I forgot that I can change the behaviour of the original MULT fader too. That’s a good workaround, but stil: This way the Custom Control fader works as intended, but I end up with the original MULT fader showing a minimum value of 0. This can be considered as a minor problem, because usually one would only use the Custom Control fader, but it’s just not like it should be.

Having a Custom Control “clone” or “alias” option for existing parameters would solve this problem perfectly, so fingers crossed that this will be added some day…


#6

I always have that global setting to show fader values as actuals turned on, so it didn’t show zero for me - it always matched the value of the custom control. I find that setting preferable to having the faders show the bias values, since the bias values can be seen too when you select the control.

Might be worth taking for a test drive to see if it works better for you too? I believe it only applies to units inserted after you change the setting.


#7

Thanks, that’s a good tip. I like the “actual” setting better too!