Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Custom Unit Controls


#1

From a blank start, I create a Custom Unit and then go to Add Control Here but I am unable to select Decibel or Pitch type controls as the cursor just flashes up the screen. The option is stuck on Linear.

Sorry if this is a known bug but I searched and couldn’t find anything!

EDIT - aha! I have to hold the button and turn! This was not intuitive to me, I expected the S1 button to cycle through the options.

(Noob) User error, but I will leave the post as the feedback may be useful!?


#2

It’s a different select mechanism, I think you turn the knob once you’ve selected the option and the cursor flashes up - if that’s not right give me 5 and I’ll check!


#3

You’re very quick Kel. I figured it out, just as I posted - which is always the way with me - I spent 5mins restarting and creating new custom units! D’oh!

Is this select mechanism used anywhere else?


#4

Hehe I just happened to be here :smile:

Not that I am aware of, it’s a bit of an outlier!


#5

Well, the S1 button is used to Toggle through a similar looking Menu. When you are selecting an Input and you are presented with Inputs Locals Globals, S1 cycles.

@odevices I see that the word “cycle” is there in this instance, but I wonder if it would be possible to make this kind of menu work consistently.

Bear in mind I am only on day 3 of using the ER301 (less than 6hrs).


#6

Time using is irrelevant I think, possibly even an advantage!

It’s a good point, it catches me out if I haven’t used it for a while :slight_smile:


#7

Just looking at it again, I think it was the fact that the cursor flashed up across the options when I pushed S1. It looked broken. If the cursor had simply not appeared, I would have tried other ways to move the selected option.


#8

I believe @odevices is planning a UI consistency overhaul soon, so something will probably happen :slight_smile:


#9

Great! I’m coming at it having seen practically no videos or tutorials and it is so intuitive and user-friendly as it is!


#10

Yeah it’s ace isn’t it!

I’m getting excited about the middle layer, tons of potential here to create streamlined bespoke units for particular tasks - minimal UI - less navigating - better performance?


#11

Yes. I’ll look at it at some point, but first I want to get to the point where I know every menu inside out. Then Teletype integration. Then Middle-Layer Alchemy. I have dabbled in Lua - but nothing as exciting as this!


#12

I admit and take full responsibility for the UI cruft that you will still find in some corners. Usually its existence means that I plan on overhauling that section anyways.


#13

Is this a good place to ask why I seem to have trouble making the toggle control work within a custom unit? I imagine its something to do with the threshhold? _What I am trying to do is have a toggle control at the top of the custom unit for punch in/out on a looper(s) nested inside. I’ve tried many different settings and I can get it to switch by changing threshhold but then I can’t switch back.? Pretty fundamental but couldn’t find the answer in the wiki or on search.


#14

You are running 0.3.25, right? The custom unit controls are being reworked in 0.4.

If so, check the header menu for the looper and make sure the punch control is set to behave how you’re expecting?


#15

Thanks Joe. Yes 0.3.25 - So the Punch latch should be on? and the custom unit toggle switch is latching. So I think I got that part right but it won’t stay latched. (Not so keen to update firmware right now - mid performances and just lost my teletype scripts…)


#16

If you are using a custom toggle then the punch latch should be off. If you are using a custom trigger, then the punch latch should be on. In other words, only one should be latching. Imagine trying to control a latch with another latch. It would require twice as many pushes!

I’ve seen this kind of misconception before but for some reason people turn off their modular (signal flow type) thinking when they start using the custom controls. Like they expect the custom controls to be “aware” of what they are driving downstream? I wonder why? Is there something in the UI that implies it? :thinking:

:loudspeaker: Executive summary :loudspeaker:
Custom controls are just signal sources. Other then the signal itself, there is no other information passing between the control and whatever is connected to it downstream. :wink:


#17

This is exactly it thank you. I think wrt the UI, when you switch between pages (on 0.3.25) there’s a quick indication that something has (or has had) signal so switching between the custom unit controls, and the deeper units, it appeared that it had latched and then had unlatched just as I looked at it (Schrodinger’s cat?). I think with a hardware when you toggle a switch you can see the effect and deduce the behaviour immediately. Also in this case, given that I was toggling the recording punch on a looper, the audio effect is not immediate either.
Anyway, thank you, I knew it had to be my misunderstanding