Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Custom Unit: Trash Tape - Realtime Crappy Cassette effect

custom-unit

#1

Hi all!
I just put together my first custom unit called Trash Tape. Its a real-time lo-fi cassette effect with controls for Wow, Flutter, Dropout, Noise, and Lo Cut.
Give it a spin and lemme know what you think. I’m still pretty new to the 301, so I’m open to improvements/suggestions on the unit.

trash-tape.lua.zip (4.7 KB)

EDIT:
I just updated Trash Tape to include a control for Hiss. The incoming signal compresses the hiss much like on a real cassette:

trash-tape.lua.zip (6.1 KB)

EDIT:
I’ve just update Trash Tape to work on firmware on v0.3.12
Its slightly different, controls are now:

Wow
Flutter
Tape Age
Lo Cut
Hiss

trash-tape V2.lua (53.0 KB)


#2

Awesome - excited to give this a spin in the coming days :+1:


#3

Nice work! running a sting patch from plonk into the smr then through this.
Sounds awesome!!!
Thank you!!!


#4

Wow, can’t wait to try this, sounds right up my alley!


#5

If anyone posts an Instagram clip using this, please tag me! - @scttcmpbll
Would love to hear other people putting it to use!


#6

Will try and hit one later tonight. As an aside, been digging your posts lately!


#7

Thanks!


#8

I tried but it doesn’t load. :frowning:
Anyone else tried it already?


#9

Are you on v0.3.02?


#10

I don’t use the Instagrams @scttcmpbll but here’s an example of a moog played into grain stretch and then effected (terribly inelegantly dropped in and bypassed at about 30 seconds from beginning and end - apologies) with parameters of the Trash Tape modulated by a global chain sin unit.

Excellent unit, thanks, works here on 3.0.2


#11

Yes. But probably it’s too late (but I was excited and I wanted to try it right away) and I did something wrong myself. I’ll retry tomorrow.


#12

Wild! Love it!


#13

Did you put it here: v0.3 > presets > units > custom-unit?
Then load a custom unit, click on it twice and load trash tape from there


#14

Great little unit! Need some tape hiss now.


#15

WOWwww


#16

I can’t find a reason I can’t manage to load this. I create a custom unit, then I load the .lua and nothing happens. If I do it with a custom unit I created myself (same folder) everything works normally, but trash tape doesn’t load. I’m on 0.3.02. Should I reflash the firmware?


#17

Are you focus pressing the unit header and then pressing Load Preset?

(Apologies for the brittle preset loading. I have plans to make it less of a hit-and-miss experience.)


#18

This is the sequence (stills from a video)

Basically it looks it’s all ok, but the preset is not there. :thinking:


#19

Don’t click “open” after placing the custom unit. Click the unit name block again and “load preset”


#20

You are attempting to load a chain preset. You need to load a unit preset which is done from the unit’s header.