Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

ER-301 possibly missing/delayed i2c triggers

My main combo is ER-301 sequenced from teletype over i2c. I have a problem that I hope can be worked out, although I realize it might be tricky, hence this lengthy post in new thread.

After some time some triggers over i2c starts to get delayed, sometimes even missed. Rebooting both modules makes everything fine again. The problem has started while I’ve been working on a new track, never had it in the past. Although it’s a bit busy over i2c, it’s not more so than usual. Triggers are send every 130 ms (16th notes at ~115 BPM), obviously at some points more than one trigger and CV is send at the same time (or as “at the same time” as is possible over what I believe to be a serial protocol). CPU usage on the ER-301 is comfortably hovering around 50%. ER-301 is running firmware 0.4.20. Between the problem appearing there have been several saves on both the teletype and the ER-301.

What makes me suspect it’s a teletype problem:

  1. Shuffling scripts around sometimes makes it happen to other triggers.
  2. There’s no way (that I know of) to tell how stressed out the teletype is, so maybe it simply can’t keep up.
  3. The delayed triggers are always on time, just a 16th note (130ms) late, super tight, just delayed one teletype.metro cycle.
  4. The delayed triggers appear visually on the ER-301 gui exactly as I hear them.

What makes me suspect it’s an ER-301 problem:

  1. At one point I wanted to try downgrading (but failed, that goes in another thread), while the problem was showing. In that process I rebooted the ER-301 without rebooting the teletype, and the problem was gone!
  2. While finishing the CPU measurements yesterday (which involves copying/pasting alot of units + clearing channels), the ER-301 froze a couple of times, so maybe there’s some memory corruption going on with the ER-301.
  3. I always think “what has changed since the problem appeared”, and the only thing (except obviously a new track on both modules) is that I upgraded the ER-301 to firmware 0.4.20.

I was hoping @odevices could chime in, maybe the above description rings a bell. I didn’t present the problem over at lines yet. Any ideas highly appreciated, since this is obviously a super annoying problem.

FYI, the ER-301 will let you keep creating units until you run out of memory and crash. There is no safety net for this situation at the moment. I don’t see how it could be related to your Teletype/i2c/ER-301 problem but you never know.

Speaking of which, the most helpful would be a minimal test case that reproduces the problem (assuming it is reproducible) without a lot of dependencies.

Same problem here!
I have er-301 teletype (old one green pcb)16n and txi all connect with i2c on a tt busboard
I always had some randim step jump
I use SC.TR.P x for triggering a kick but some times appear a step jump or beat eating …

A minimal patch and teletype script would greatly help here. :bowing_man:

Just a side note: i’ve seen similar behavior with Just Type (especially Geode). Not with ER-301, however. Green PCB TT and no busboard here.

I send a quicsave + tt scene to @odevices, I encourage @Mooko to do the same!

I’m so glad that I’m not alone with this problem! Did you bring the problem up over at lines, @Mooko? If not, maybe one of us should start a thread, and the other one could chime in.

I think it would be a good thing to ask ourselves questions and compare answers, a few that comes to mind:

  1. Firmware + hardware version of teletype + ER-301
  2. Expanders/other stuff on i2c
  3. Does it happen with hardware outputs also?
  4. Under which circumstances does it occur?
  5. A simple as possible tt scene and 301 quicksave that will reproduce the problem.

No not yet Because before I wanted to be sure that it was not a problem with I2C cables or i2c power …
But now I have a tt bus board and same problem
I try in other cases other power brick with an lipo battery
I change i2c cables try differents configuration with just teletype and er-301 and i alaways have
the same problem

Ok, makes sense!

There must be more users having this problem, can’t just be the three of us (counting @joe_biomassa in as well)…

Should I start a thread over there later today and you share your experience in the thread? Are you also @Mooko over there?

I also have noticed similar issues but I’m also using a faderbank, that’s a lot of messages sent to the 301 and the TT metro might also lose accuracy after a few minutes. Never solved. Here’s the link FYI https://llllllll.co/t/teletype-workflow-basics-and-questions/12392/695?u=nordseele

I started a new thread over at lines describing the problem. I hope @Mooko, @joe_biomassa and @Nordseele will take the time to join in with your observations, so we can all help shed some light on the issue and hopefully get to the bottom of this!

2 Likes

Here’s a little test scene + quicksave + two videos, one where the state is bonkers, timing is completely messed up, and one where I reboot and everything is fine: tt_301_i2c_test.zip

Only SC.TR.P 1 (script 1 = lo sound), SC.TR.P 2 (script 2 = hi sound) and SC.TR.P 3 (I script, resets the counter T, and a disabled counter unit on the 301) are read by the ER-301 and the ones that are being heard. The rest (teletype scripts 3-8) are just sending stuff out of all the other holes…

I had to play a bit with the scene to get to the messed up state, I’m gonna see if I can find some reproduce-able steps. ATM its running fine since after the reboot 30 mins ago…

EDIT: Oops, just heard a minor hickup, while typing this :slight_smile:

Thanks! On it now!

Thanks a lot! I spend a lot of time today trying to get a reproducible pair of scene and quick save, but it still eludes me exactly what makes it trip.

@odevices of Course!!!
a link with 2 videos the quick save and the TT script.
delay & step jump problem
I always have a little delay (you can see the little delay on the red led flashing in 4th note) and some random step jump on Kick/Clap sounds

Hi, I think I encountered this this evening. I just have teletype triggering a kick sample. The setup is SSF URA clk out -> Teletype input 8 -> EVERY 4: SC.TR.P 2. It works for a good while, but after a half hour or so, it gets out of sync and the only thing that will cure it is a hard reset. Even loading another scene on teletype with no SC commands, and then reloading the 301 scene after a couple of minutes does not fix it.

I’m going to let it run again to repeat the problem and then try the 301 reboot to see if this results in a resync…

I’m not best of friends with EVERY, they tend to have their own life. Did you try if SYNC -1 would fix the problem?

After further tests last night, it wasn’t just the EVERY. All triggers start behaving badly. Also, (posted in the teletype basics thread earlier) some CV commands are wonky too. Slewing CV doesn’t work at all.

I had to go to sleep before further debugging. It appears to me that i2c between er-301 and teletype is very broken currently. I looked through some of the firmware on the teletype side and it looks fairly consistent with the other i2c implementations, nothing obvious there.

The other thing I’m beginning to question is my config. I am using with a Telexi. I have the telexi in the (looking at the back of teletype) left 3 pins of the i2c header, and the er-301 hooked to the right side. I did not want to try chaining connections. Everything mostly works when power is first applied, and the Telexi is pretty solid throughout.

1 Like

Sounds like you’re as exhausted over and frustrated about this issue as I am :slight_smile:

As I’m about to install a second txo into my i2c setup, I asked a few noob questions over at lines. One of them was, if it is actually (still) recommended to daisy chain i2c. Like you I’ve been running a “star configuration” using (here) two of the four i2c sockets on the teletype. When someone smarter than me answers over there, the conclusion might be that we should try daisy chain instead of star, and see if that by a stroke of luck, would improve/solve things…

Here’s the recent question on lines:

Yeah, I’m a bit frustrated. I spent a bit of time figuring out why some scripts weren’t working but it turned out that when I switched over to physical connections they worked fine!

I believe we will get it worked out though. My suspicion is that it is on the 301 side. I think if it were on teletype side we would be seeing a lot more symptoms with the other modules. From what I can tell the 301s command are mapped pretty directly to the TO commands in the teletype firmware.

Sounds like you can more faithfully reproduce than me. Maybe you can send me a set of scene + quicksave that always shows the problem and I can test drive it here (a bit pressed the next month, but I’ll try).

What we could (should) do is when the problem occurs, switch to both buildin physical connections on tt and txo and see what happens. If it works fine through txo, to me that would suggest it’s omsething with the 301, if the problem is still there with txo it suggests its on the teletype end.