How to convert a gate signal to a trigger?

I want to control the punch of a looper with an external sustain pedal, but the looper state sometimes gets confused with the signals from the pedal, as it is a gate. So if I do not just tap on the pedal, but let my foot on it for a second or two, the looper thinks the changing gate when releasing the pedal is meant to fire the punch again.
So how can I change the gate signal to a trigger, that just fires the pedal down activity?
Thanks for any hint!

Have you confirmed that you are actually getting a gate from the pedal? Sustain pedals are typically passive devices (i.e. just a switch) that do not produce gates.

Typically you would need a separate module to interface with an external food pedal like these:

Thanks Brian,
I am using exactly this ADDAC module to get my sustain pedal into the modular world. The output is a gate.

Hmm. In that case, it sounds like your gate is noisy. :thinking: May I have confirmation that you are using a foot switch and not an expression pedal?

If you are indeed using a foot switch then you might need to debounce it by adding a low pass filter.

Yes, I use a sustain pedal, not an expression pedal. Foot down closes the switch in the pedal which opens the gate, foot up opens the switch and therefore closes the gate again. The problem is, that the closing gate triggers the punch again, which means the looper stops recording. But I want it to stop recording only when I tap on the pedal again (foot down). So only the foot down (gate open) information should be interpreted. Or is this the normal behaviour?

I just read this in the Wiki for the feedback looper:

This parameter is used to punch in or out when recording. It supports both momentary and latching behaviors. If the Punch Latch setting is ‘on’ then this setting behaves like a toggle such that a rising edge punches in and the following rising edge punches out. If the Punch Latch setting is ‘off’ then the unit is punched in only while this parameter is receiving a high value.

I have not seen the additional setting regarding the behaviour of the punch. Will check later, which setting it is currently. Maybe this explains the behaviour already…

The looper unit’s controls are indeed already configured to behave the way you want (default is always latching enabled). However, based on your description I am guessing that your gate is noisy. What I mean is that you are not providing a clean rising edge but rather it goes up and down quickly (bounces) before settling on the high (foot pressed down) or the low (foot released) values. It is so quick that you cannot see it in the scope. This is why I suggested inserting a LPF or slew limiter after your foot pedal. This process is called debouncing.


  • Try recording a couple of pushes of your foot pedal signal using the 6-track recorder and drop it here as a WAV file for me to look at.
  • Try putting a Slew Limiter unit with time set to 50ms in the sub-chain of the control that you are trying to trigger.

Thanks Brian, The noisy gate explanation makes sense to me…
I will play around with all this information and will post a WAV when I can not fix it myself.