I2C setup with 16n Faderbank

Raph emailed me a hex file that worked… I was having trouble this week, but that solved the problem. That and waiting for the 301 to fully boot up before powering the 16n. I’d shoot him an email re: the firmware…

Open the Arduino app
Look on the top left - and click the 4th button that says Open “arrow up icon”
Goto the folder where you downloaded _16n_fader firmware ino and open it
Make sure all the other firmware files are in the same folder.
When opened, goto the 4th Tab “config.h”
Make your setting by uncommenting removing the “//” bits you want like Master, LED 1 and Flip 1, Rev 1
Goto -> Tools menu and select these settings
Board: Teensy LC
USB Type: MIDI
CPU Speed: 48 MHz
Optimize: Smallest Code with LTO"

Connect the usb cable to the mini usb on the Teensy
This next step will upload from Arduino app to Teensy app to Teensy
Click the 2nd button in the Arduino app in the top left - the one with the “->” or "Upload’
The Arduino will now compile the sketch and auto open the Teensy App
check for any errors on the bottom.

  • if it says you are missing a library - goto Sketch -> Include Library -> Add .zip file
  • and run the upload again.

When the Teensy app opens, click the Auto (green button in top right) of Teensy app.
Manually press the button on the Teensy.
The hex file should upload to Teensy and auto reboot.
Check there are no errors when it finishes, It should say OK.

3 Likes

I had similar issues with my MI Synthworks 16n. Everything worked fine after I uploaded this firmware to the 16n:

16n_firmware_v133_I2C_MASTER.hex.zip (32.8 KB)

3 Likes

Yep, as Scott said, you really do not need to uncomment anything, there is an official release which has master settings (I linked it above, Scott uploaded it). Just upload it via the Teensy loader unless you want to tweak the settings somehow. The only other thing, I assume you have a rev10 or a modded rev7 301? (The cables on the rev7 were confusing to me). Good luck!

1 Like

Working! Yeeeees! This is literally my favorite addition to the 301 ecosystem ever!

12 Likes

Anyone here using 16n with TT, both in Master mode controlling the 301? Any success?

I’m having this issue where the 16n works for the first couple of minutes before hanging, tried all different types of firmware including the latest 1.34, same issue. TT and 16n are not broadcasting on any of the same i2c numbers.

Having two single masters (err, uhh, leaders) on the same bus is almost guaranteed to cause problems eventually. It’s irrelevant what “ports” the two devices are addressing, the conflict is on the bus.

2 Likes

Yeah got the same advice on Lines, changed to follower and its working well. Thanks!

Okay, so I’ve been trying to get this to work but… how do I set the port? Is it the Bias?

This is what I opted for, but the female jack I got has no indication of which of its 3 connections = tip sleeve or ring. Any pointers here? There is one long prong, that I assume = Sleeve and I am just guessing one to left is Tip and one to Right is SLeeve, but… shrugs

Is this step necessary if I just purchased direct from Michigan Synth Works?

If you’ve got a multimeter with a continuity tester in it, simply plug in the trs cable into the jack and check for continuity from the tip of the jack and then to each of the lugs on the input, if it beeps, you have a match . :slight_smile: Do the same test for the ring and sleeve of the cable jack also and that’ll confirm whats what.
Hope this helps.

Correct.

I believe so yes. I’m pretty sure the firmware that Raph ships them with has them set to slave and you need to change the firmware to be master.

Now if feel stupid. Yep that worked. Now I know what’s what. I think everything is wired correctly now and I just need to flash the firmware on the n16

1 Like

Ok. I am totally stuck here. I have everything in place, but for some horrible reason, the firmware continues to fail to compile, citing that I’m missing CD74HC4067.h even though I have that library in the same folder with everything else. Any ideas how to fix?

Did you add CD74HC4067 manually, or through the in-app library manager?

Manually. Let me try the manager… yep that was it.

1 Like

So after I built I discovered that this is the board I should have built for, BUT now Arduino will not let me select this board. It’s stuck on 3.2/3.2.1. Any ideas on this?

1 Like

Nevermind. I just had to close it all out and restart. That did it. EVERYTHING WORKS NOW!!! YAY~!

Now… how do I actually set up the SC.CV to manipulate things on the ER-301? I have created several at different ports and am getting signals when I move the sliders. What’s next?

3 Likes

Just drop in the SC.CV to what ever you want to control, assign a fader number, go back up a level and adjust gain/bias to taste. Voila.

1 Like