Ignore trigger until slice end?

Hello everyone, slowly getting to know my Er301. I was wondering if the following would be possible: create a sample chain, or slice an existing sample and trigger it, but only trigger when the slice is finished? So ignore the incoming triggers until the currently playing slice has reached its end.

Don’t know if this is covered before, can’t find it anywhere on the forum.

1 Like

How about an Envelope Follower that is rigged to close a VCA? The triggers should be fed through this (attenuating) VCA, and the trigger threshold on the Sample Player should be set so that it only fires on a full strength trigger.

1 Like

That could work, yes! Simple, yet effective. Will try tonight. Thanks!

1 Like

have you tried it? am on a similar journey

working on it. Building a patch. Will post it here once it is finished.

1 Like

thanks, am working on it too, but I don’t make any sense for now…

Apoligies to come back to this so late. I was out sick for a while. Tried to set this up today. I have managed to set up a varispeed sampler that plays random slices and assigned an envelope follower to the output of the sampler.
I am triggering the sampler gate with a clock and put a vca after that clock. I am struggling with the “envelope follower to close the vca”- part. I just don’t get it. I am sure that is just me being new to all of this, but I just can’t dial in the right settings for the gain/bias/trigger treshold.
Can someone please try to explain the steps I’d have to take or the values I need to dial in? I think I am very close, just need to connect the last dots.

in particular: how do I get an envelope follower to close a vca? I should invert the signal somehow, but I don’t know how. I have tried negative gain on the vca, but that doesn’t seem to work. Maybe it is just me not understanding the gain/bias thing. Any help is appriciated. I am sure it is something really simple that I am overlooking. Or is there a simple inverter unit?

So you want to use the envelope follower to indicate when the slice is playing, when it’s playing the signal will be high (1) and when it’s not it will be low (0).

For the VCA after the trigger you want it to be open as long as the envelope follower isn’t 1, so set the bias to 1 and gain to -1. That way when the env follower is high the VCA will be 0, fully attenuating the triggers.

Edit: to take it a step further you can use the or unit from lojik to quantize the env follower output to actually be 1/0 instead of some value in between.

2 Likes

This is very important to know for modular in general so let’s make sure you have this solid. First, have you read this?

Control Types: Gain/Bias

Pay attention to how the gain is applied to the modulation signal before the bias (e.g. offset). This is illustrated in the UI:

gainbias

So following the arrows:

  1. modulation arrives from the sub-chain,
  2. first it is multiplied by the gain,
  3. then summed with the bias.
  4. The result is the parameter’s value (VCA level in this case).

Now, let’s assume the envelope follower (EF) is sweeping from 0 to 0.5.

  • When EF is 0, we want the VCA level to be 1, so set the VCA modulation bias to 1.
  • When EF is 0.5, we want the VCA level to be 0, so set the VCA modulation gain to -2.

Your VCA should now be closing. Of course it might not be closing all the way all the time but for this application you don’t need it to.

3 Likes

Just to drive the point home, the (modulation) gain/bias concept is all over modular already:


(Reference: Intellijel uVCA II: The most clearly labeled VCA in eurorack.)

Here is another way of looking at the Gain/Bias control. It is like having an A183-2 in front of every CV input.
text39810
(Reference: Doepfer A-183-2)

2 Likes

Thanks a lot Brian. I understand how to close a VCA using an enveloppe or an envelope follower in my system, just didn’t get it inside the ER301. I’ll try again tonight when I’m home from work. Thanks for your patience and the clear explanation.

So I have found something that works a little bit.

First I was struggling with the envelope follower. But I found the following setup: I could not get it to work unless I put it right behind the varispeed sampler. But it sounded distorted because the signal got distorted because of the slewing. So I put it after the sample player and bypassed it. Then routed the EF signal to the vca. Vca with a negative gain of -2 and a bias of 1.

Now I got it working as I want it more or less, but not entirely.

If I put the trigger treshold to 1, nothing happens. Same for 0.99, 0.98 and 0.97
If I put the treshold to 0.96, I can fire it up manually, it keeps going for a little while and then it stops. Same for 0.95 and 0.94. The lower the treshold, the longer it goes. But it still stops. Once I put the treshold to 0.90, it seems to be working all the time.

So it looks as if the vca is not entirely opening. Which should imply that there is still some sort of signal passing through the EF. Which is not possible, because when the slice is finished and the sampler stops, there should be no signal and the vca should open fully and the clock would pass through. I’m sure there must be a simple explanation. And maybe I am overthinking it. But I’d like to grasp what is going on, in order to better understand the functioning of this module…

This might help, I made a video showing how to do this using the Or gate which includes where to put the envelope follower:

2 Likes

Thanks Tom, will try tonight and get back to you with the results!

Thanks Tom, I have understood a few things after watching your video. It is working as it should be now.
I finally found the problem. As it turns out, there was something wrong with the sample chain I was using. It was always stopping at the end of the same slice. I don’t know why. But it was playing slices in random order, that’s why I didn’t notice. I deleted that slice marker, and now it works flawlessly.

One question: why do you add a negative offset before the or gate? To make sure it is fully closing?

The envelope follower slews down to zero but will always be slightly above zero. So you have to bump it down a bit to get the zero crossing to register properly.

That’s what I was thinking, and it also explains a lot of troubles I had before. Thanks for the “or” tip. That really makes the triggering real tight.