Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Issues with step record and firmware update

support

#1

Hello, so i am having issues with the step record feature. I use a tetrapad to adjust the cv-a / cv-b / gate / duration in fader mode. Everything seems to work fine but the duration. It is stuck at 41. Even when i dont plug anything into it as soon as i send a gate to the insert it automatically makes the duration 41. Anyone else having this issue?


V2.xx: ER-102 Firmware Discussion
V2.xx: ER-102 Firmware Discussion
#2

oh and i probably should have mentioned i am on er 101 firmware v2.09 and er 102 v2.12. I also tried different PSU (TT mantis / uzues) and switched patch cables to make sure it wasn’t something like that.


#3

Be aware that the firmware for the ER-102 is up to v2.19


#4

hm i am think i might be an idiot i will have to load that up right now


#5

ok now i am thinking this is obviously a user error, I am having trouble loading the new firmware though. When hold the punch button it only show as 2.12 loaded on the er 102. When the ER 101 is in sudo mode and i hit reset while holding the punch in it shows 2.12 but i will can’t pick anything on the SD card (i only have 2.19 on it).


#6

Did you put the new firmware in a directory called “Firmware”?


#7

yeah here is where it is on the microSD


#8

It’s had for us to know what you are doing, would you carefully write down the process or make a video perhaps?

Are you following the update procedure as outlined at the end of the manual?


#9

hi kel, i follow the manual. I updated the ER 101 to v2.09 with no issues using the programmer. After that i downloaded the ER 102 firmware v2.19 i followed everything in the manual. When powering up the er101/102 with the punch button pressed and the switch set to admin it boots up and show the version for both the ER 101 and 102. When i hit punch again nothing happens (no pendulum led or GOOD comes up on the display). If i hole the punch and hit the reset button it just shows the current firmwares (101 - v209 102 - v2.12). I will try to make a video later but it seems like the ER-102 is not reading the microsd card. I have used the one that came with the ER-102 and have never re-formatted it only dropped the scales and firmwares from this site.


#10

Sounds like you did everything right!

I wonder if it is just the version number that is displaying wrong and that it has actually upgraded. Perhaps test some functionality from the new firmware and see what happens?

Also check to see if you can save a sequence to the SD card.


#11

that might be the case i will try fiddling with it tonight, its weird though because when i go to load it nothing happens. i don’t get the “good” sign on the 102. I think when i loaded 2.12 a while back i remember it doing everything exactly that the manual said.


#12

here are videos of the issues i am having, the 1st video is of loading the firmware and the second video is the problem with duration in step record mode.


#13

hi just bumping this to see if i am doing something wrong or if maybe the 102 has a problem


#14

I wish I could help, but I don’t know what is wrong and I think you might just have to wait until @odevices returns from his holiday!

I know it’s frustrating, I really wish I could help.


#15

on man no problem, i know how it goes, i can be patient


#16

have you tried formatting the card, or using a new one?
or maybe reinstall the newest firmware for the 101 with the 102 (not with the programmer)


#17

yeah i tried a new card that was formatted no cigar


#18

hey just bumping to see if maybe i am making a mistake updating the 102 or if maybe my 102 has a hardware issue.


#19

In the first video, the ER-102 never enters firmware update mode. Could you send me a zip archive of the contents if your SD card please?


#20

ER-102.zip (159.3 KB)

Here you go