Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Late ER-101 reset from Beatstep Pro


#1

I’m clocking my ER-101 from the clock out of my Beatstep Pro, and attempting to reset the ER-101 sequence by using a spare track in the BS Pro Drum Sequencer. I programmed a single hit on beat 1 of the BS Pro sequence and sent it to the ER-101 reset input.

However, the ER-101 reset is happening 1/16th note late. It’s behaving as if the reset pulse is being sent late by the BS Pro, but I’ve tested the output of ‘reset trigger track’ of the BS Pro and it’s perfectly in sync with the clock.

If I re-program the reset pulse in the BS Pro sequence on the last 16th note of the bar, it triggers the ER-101 reset correctly.

However, this is not much use, as the ER-101 then doesn’t pick up sync until bar 2, so it’s 1 bar out of step (and my first bar is always a mess).

Any ideas anyone?


#2

I’ve tried this setup with 2 other sequencers and they both reset to beat 1 as soon as they receive the reset pulse from the BS Pro


#3

What firmware version is installed on your ER-101? And also your ER-102 (if any).


#4

Hi Brian - thanks for the swift (as usual) response.

ER-101: 2.09
ER-102: 2.19


#5

I’ve just updated the ER-102 firmware to 2.21 but it makes no difference.


#6

By the way, I’m running the ER-101 at 4 ppqn


#7

Further tests: If I clock the ER-101 from Pamela’s New Workout and use a 2nd PNW output to send a reset pulse on bar 1, beat 1, it resets the ER-101 every time - all good. I don’t understand the problem with the BS Pro.

However, if I stop the PNW clock while the sequence is playing and when the ER-101’s gate out is high, the gate stays on high whilst stopped. The next time I start the PNW, srep 1 in the ER-101 sequence doesn’t send a new gate high signal. As the gate is still high from the previous time, it needs to be sent back to a gate low condition before it will trigger a new gate high.


#8

It sounds like the BSP reset is coming too late after the clock.

The ER-101 will wait 0.5ms after a clock pulse to see if a reset signal will arrive. If a reset does not arrive then it will go ahead until the next clock pulse.


#9

Yes - it would seem so, but it looks OK on the scope, and surely, as it’s derived from its own internal clock, it must be in sync with it?

PNW reset pulse: instead of sending the reset pulse from the PNW on Start, I’m now sending it on Stop, which solves the previous problem.


#10

The PNW clock and reset signals are known to be very tight.

You say you looked on the scope but you leave out any mention of the time-scale.


#11

This is the expected and desired behavior by the way.


#12

Understood. My ‘Reset on Stop’ procedure makes it rest OK now, with a gate low state every time.


#13

I must admit - my description "looks OK on the scope’ is a bit vague!


#14

I don’t have the ER-101, but do have a BSP. I’ve found the timing on it to be very tight. Not sure if any of this will help but:

  • What firmware version is the BSP on? Arturia has done bug fixes in their firmware too.

  • Does the ER-101 expect a trigger or gate for reset? By default the BSP drum sequencers drum gates are pretty long. You can adjust them to look more like triggers with the gate time parameter. I have encountered a couple of situations where decreasing the gate length solved a problem for me.

  • There is also the shift parameter for each beat. Did the event get shifted to come late, accidentally? If not, would shifting it so that it comes a little early help?


#15

It doesn’t care.

Allow me to re-iterate for emphasis. You have 0.5ms to get a reset to the ER-101 otherwise its going ahead without you!


#16

Thanks Joe - in response to your points:

• My BS Pro was on firmware 2.0.0.2, but I’ve just updated it to 2.0.1.6 but it makes no difference to my problem

• see Brian’s comment re gate/trigger

• The ‘Shift’ parameter for the BS Pro track I am using to reset the ER-101 was set to 0. I tried using it to advance the timing (-01 is sufficient) and, once the sequence has started, it kicks the ER-101 into sync, but for obvious reasons, the advance doesn’t kick in until after bar 1, beat 1. You can’t have a start pulse before the clock starts. This means that I have to wait until the end of the ER-101 sequence cycle before I get sync.

I like using the BS Pro as my master transport control as the Start/Stop buttons are right in front of me.

I’m going to have to try to use the the BS Pro as a master clock for the PNW and use the PNW to trigger the ER-101.


#17

Sounds like the BSP has a slop factor > 0.5ms then. I guess you could send a manual reset prior to hitting play by just tapping the drum pad? And let the shift = -1 take care of it from there on? Not ideal, really, but might be a workaround.


#18

Yep. Not ideal. I’ll see how I get on using the PNW with the BS Pro.


#19

I’d be interested to hear if that works out. One other thought - kind of a long shot. I imagine the BSP is single threaded. If, for example, you’re using pad 8 for the reset now, I wonder if pad 1 gets processed first. Maybe switching to it would get you inside the 0.5ms window.


#20

That’s not a bad idea… I’ll check it out

Thanks