Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

My ER-301 won't start anymore, help!

Today I went tomy system, turned it on and the ER-301 won’t start. Only the PWR red LED is turned on in the back and after a while, a green LED turns on too. But no light on front panel or LCD :frowning:

Have you tried reseating the card on the back?

Is the rear 5v switch set to ref or bus? Has your case lost 5v power?

Also - you could try taking the rear card, mounting it on your computer and then unzip the er301 firmware to it.

Hi there, my case is powering all other modules correctly. I have done all the tests that you are suggesting but still not starting. I still have to mount the card and unzip the operating system though. Are you suggesting that the filesystem went corrupted for some reason ?

I was suggesting the 5v check because not that many modules use it.

The rear SD card / firmware is more of a guess as it’s another variable but I think at this point you should email Brian and get advice from the source.

SD card failure has happened once or twice before so it is worth trying another one.

BUT the rear card needs to have its first partition marked active (which is not typically true for a factory-fresh card).

I use the DISKPART tool on Windows to make partition #1 active (i.e. bootable).

So the one I need to mount is the rear card which is the one that holds the OS right ? The front card is just storage memory ?

Yep!

Guys, I have tried the Micro SD card on a phone as I can’t mount it on my computer and it works … There are three files, kernel.bin, MLO and SBL … so the kernel is there and I think the card works properly …

Just mounting it on your cellphone, is unfortunately not a conclusive test because it is possible that a few clusters went bad inside the MLO (which is the primary bootloader).

Things that I would try (and the order in which I would try them):

Is the ER-301 getting enough power?
The best test of this is to try powering the ER-301 on its own.

Has the rear SD card failed?
Using a fresh card, mark its primary partition active, copy the kernel.bin, MLO and SBL files to the card from a fresh download (do not copy the files from your old card).

Has the CPU board failed?
The CPU board is the red 40mm x 60mm board on the back. It is easily purchased directly from Olimex for about 33EUR:

Swapping it on your own is quite easy if you take your time and are careful when pulling it off and putting the new one back on.

Send it back to O|D (me).
Let me know and I will give you further instructions in private. If you prefer to just skip right to this step that is fine.

I will try all of this first and report you back, thanks for the debugging information !

How many disk partitions do I need on the card ? Just got a card reader and will do it now

Just 1.

But - needs to be marked active (so it’s bootable).

What filesystem ?

FAT32 i believe

Ok, just did. New card, marked partition as active, the ER-301 doesn’t start …

I am following and hoping for a happy ending, but I am struggling to know what you have tried and what you haven’t.

May I suggest going back through this thread, copying each ‘test’ and writing a response for each one. My favourite is still not enough power and I can’t tell if you have tested this or not from what you have written.

My case has Tip Top Mantis, how do I test if it has enough power ? I’ve got 5 more modules and they are all running. Sorry but I am a n00b to eurorack

Unplug everything else and just try running the ER-301 in the case. Always be careful about how you plug things in regarding the red stripe. I burned up a unit early on by being careless about this serious issue.

Looks like a 3 Amp power supply, with 5 other modules it’s hard to imagine this is not enough but I guess it’s possible. A super easy way is to load everything up into ModularGrid and it will tell you what the total power consumption is at the bottom of your rack.

Other than that just add up the -12v, +12 and +5v power requirements for each module, make sure the total for each voltage doesn’t exceed the maximum available on each one and doesn’t exceed the total amount of power available.

Please check you haven’t plugged any power cables in the wrong way!

To be on the safe side, unplug everything first and then use a small multimeter to test the voltages on the power rails, set your multimeter to a suitable voltage range, I usually use the 20v setting, connect the ground probe to one of the ground pins on your power suply connectors and then touch the -12v, +12v and +5v pins in turn and check the reading is about right - it won’t be exact. This is worth knowing how to do anyway.

Also, as suggested, just try powering up the ER-301 on it’s own, i.e. unplug everything else.

I just did, now it’s plugged in just by itself, no signals of life. Only on the processor board there is a red PWR led on and a green led also on.

The er-301 was my first module and I never changed its position on the rail, it just didn’t start all of a sudden. What should I do now ? Change the processor board ?