New user: which firmware 0.2 or 0.3?

yeah, the flow of patching is no different. The only videos that will be different are the early sample slicer videos and maybe the first custom unit video before the interface for it was tweaked.

Once the GUI stabilizes I’ll do another overview video :slight_smile:


Ugh. First patch, machine crashed. I upgraded before using it without a problem. Then I patched some audio in + clocked delay, while I was recording. When I added another chain and a grid quantizer it froze. Tried the same patch again and it froze again. Am I doing something horribly wrong?

So I started some first experiments with my brand new ER-301 and had three crashes in on hour of usage (during which I mainly read up on the work flow).

This is the patch I was trying to record on two channels:

Audio in on channel 2, clocked delay, immediately out again.
Audio in on channel 2, grid quantizer and immediately out again.

That’s it. Tried it three times, crashed three times. I don’t think i overloaded the poor thing did I?

This is firmware 0.3. I had many people telling me it didn’t crash and was stable enough for basic usage. Do I need to be aware of something, am I using it the wrong way?

EDIT : also, is plugging the power the only way to restart when it crashes?


In order to help me reproduce the crash, could you please describe at what point exactly the crash happens?

Hello Brian,
There doesn’t seem to be an exact moment. I just tried it again and here’s what I did:

- Audio in Ch.2 --> grid Quant. --> Audio out
// All good
Then I started recording one channel. // All good
Then I stopped recording, loaded my very simple simple clocked delay preset, and started a two channel recording
+ Audio in Ch.1 --> cl. delay --> Audio out

All good for about thirty seconds after which it crashes again while I am navigating around doing nothing special.

Thanks for the response by the way, that’s really nice.

Hmm this sounds just like the problem users were having with their SD cards while recording.

I wonder if I got a bad batch of bad SD cards? :thinking: I’ll definitely look into this. In the meantime, it seems like reformatting your SD card or trying a different one could fix the issue.

You are very welcome, by the way. :wink:

1 Like

Hello Brian,

I’m sending you some more test results. Not going great I’m afraid :frowning:

I reformatted the included sd-card. There was like 4MB of unallocated space on there and I hoped that would have been the issue. After reformatting and checking for errors, initializing by the ER-301, I did another attempt of my famous first patch described above (it’s safe to assume that this particular chain is not causing the trouble but that’s what I got wired at the moment). I was hopeful because the machine lasted a while longer. But after some navigating around and changing some parameters the behavior returned. I mean the lack of behavior: total freeze up.

Then I swapped to a totally different card. This was a Kingston 8GB. This one didn’t last long. So that rules out the bad batch of sd-cards idea too I think.

When I’m not recording it’s all working great, so there’s the issue right there. One of the main reasons I got this unit was the prospect of recording in the box, however, and even multi-track recording! That’s why it was the first thing I started testing.

I will check that other thread you linked to above, and meanwhile test the unit without recording. Oh wai, maybe I should first try downgrading to the other firmware? After all it shipped with 0.2 installed.

No it does not unfortunately. I believe the problem arises when the SD card is too slow. An SD card may be slow for various reasons (fragmentation, bad clusters, slow speed class, etc.). You can test to see if your Kingston 8GB SD card is fast enough for recording by going to Admin > Card Console > Measure Speed. The measured write speed should be at least 6MB/s which requires speed class 10 or better.

Worry not. I will get you to a working 6-track recorder. Probably the quickest route is to go on Amazon and purchase another 16GB or 32GB class 10 or better uSD card by a reputable maker such as SanDisk or Toshiba or Transcend.

My task is to fix the freeze which shouldn’t happen even if the SD card is too slow.

You can try but I doubt downgrading will improve the behavior.

Well I guess a helpful error message would be more reassuring for new users like me :wink:

I will get a fast SD card ASAP and will test. Maybe I’ll try the one in my camera right now, that should be a fast card.

FYI, I’ve just released a firmware that might improve things for you:

Please update to this firmware (v0.3.07) and reformat the card that came with your ER-301 again but this time use the ER-301 to do the formatting: Admin > Card Console > Format Card (S2).

1 Like

Hi again, I have upgraded to the new firmware. I wasn’t able to repeat the tests because now the system fails to mount the SD-card :confused:

I tried it with two different cards with the same result. When I restart the unit with the card inserted it seems to work because the card gets initialized during the startup. Then when I want to go through the formatting process, the system unmounts the card and fails to remount it (that’s how it looks like).

So if I understand correctly, you can format both cards on the PC but not in ER-301?

That is correct. I formatted the card on my pc and it is mounted when present at power up (in the ER-301), but when I attempts to re-format it as suggested, it rejects the card and doesn’t want to mount it again after that.

After this,I copied my original files manually on the card, inserted it in the ER-301, and attempted again to record, without first formatting the card, but this still freezes the unit. (but I suppose the improvements are only made when the card is formatted by the ER-301)

This is definitely a card problem then. It is a nightmare trying to find a decent bulk supplier for SD cards. I’ve tried so many and wasted more money than I want to admit.

I have always found Sandisk cards to be very reliable in all the years I’ve been using them, I can’t actually think of a single problem.

I will order a good steady SanDisk then and meanwhile use the unit without recording and be happy :slight_smile:

I just tried it for the first time and I am experiencing the very same behaviour with the originally included card.

  • Recording instantly let’s the 301 crash.
  • Formatting the card makes it unusable but does not format anything (still readabl on the computer, plus there is a temp file now)
  • I did a speed test before and got 0 Mb/s for writing and reading.

My ER-102 should be ready to ship in the next days - will it be affected too by this?

EDIT: I found a Sandisc card in my Radio Music and it works now.

Though the new formatting routine decreased the reading speed from 9.20 to 6.10. Is it still recommended to reformat the card?

sec. EDIT: In the old card backup I did on the computer there is a folder “sc” and a folder “v.03”. Both contain the same subfolders which I also find on the new formatted card - which one is the one I should copy to the new card now or am I allowed to just copy it into the new file system or have I just start from scratch?


The v0.3.xx firmware will create a completely different set of system folders (in ER-301/v0.3) and operate independently of the previous v0.2 release (which creates its folders in ER-301/sc). The only shared folder is ER-301/recorded.

I’m pretty sure it will not.