Noise when modulating delay time with an analog signal

Hey Y’all,

Finally diving into the 301, it just arrived on Monday! I’m having some issues using external CV, either through INx or ABCDx on the Doppler Delay.

I made a really simple sin+adsr+vca patch, through a doppler delay.

Modulating the Delay time with the big encoder was fun, sweeps around nice, nice smooth pitch shifting time effects. So then I dropped in an (internal) SINE OSC at a super low rate and used that to modulate the Delay time, also smooth and great.

I cleared that SINE OSC out, and assigned the A1 at 1.0 gain. Instantly without anything plugged into the input, a significant amount of background noise started entering the delay buffer. I plugged in an offset module (Triplatt, also tried Cold Mac, also a Dixie 2 OSC and Monome Crow running an LFO) and any voltage movement completely destroys the buffer. I added a SLEW LIMITER to the input chain, and that cleaned it up a tiny bit (tried from 3ms to 2sec), but it’s no where near the smoothness of using the encoder or internal modulation.

I’ve tried assigning the offset modules to other typically sensitive destinations like pitch or VCA level on a low freq SINE wave, and haven’t seen this issue, so i think maybe it’s the doppler delay module? I don’t have enough experience in this playground to know. Should I be regularly adding modules to my CV input chains?

Any thoughts on what I should try here?

(also fine if this needs to be split to another thread)

1 Like

I can reproduce this, and I’m pretty sure you’ve found some kind of bug. I would not expect any noise to be introduced into the audio path by doing this. Tagging @odevices for awareness.

Congrats on your new ER-301!

1 Like

Firmware version?

I tested on 0.5.01

I tried on the latest v0.4, 0.5.01 and 0.5.02. Also just tried using i2c from crow to modulate, same issue.

I think there is some noise being introduced into/by the modulation, and that’s causing the audio to get fuzzy.

Okay, @slowwild threw me off when he said it completely destroys the buffer. This behavior is normal.

  • Analog signals will always have a small amount of noise.
  • Modulating the delay time is equivalent to modulating the playback position of a buffer.
  • The delay time on all delay units is unfiltered for maximum versatility.

Hence the “fuzziness”. If you want to control delay time (or any noise sensitive parameter) with an external/analog signal then I recommend putting it through the Deadband Filter unit (created for this purpose btw) and then if desired the Slew unit.

These are not actually that sensitive when compared to delay time (aka playback position). It’s more a question of naturalness. Small variations in pitch or loudness are familiar but small variations in time are not. From a signal processing perspective, jumping randomly around (even a small part) of an audio buffer creates high frequency artifacts.

1 Like

awesome, sorry for the rough description; I was sure there was an explanation.

Is there a way I can match the feeling of the encoder/internal modulation with an external source?

I added the deadband, and that filters the noise even through a slew, but it’s much steppier, and you don’t get the slewed “tape effect” that comes from the encoder.

I’ll play with the times and thresholds there to see if i can match.

Don’t forget to experiment with the gain too. Also, if the linear slope of the Slew unit doesn’t suit you then you can get closer to the exponential curve of the encoder with an LPF (set the cutoff to around 1-5Hz and Q=0) instead.


I must confess I have never used the Deadband filter. Nothing had ever come up where it seemed needed. Now I know. :slight_smile:

1 Like

@joe Would like to know if you can dial this in, I’m finding it hard to get any desirable results here.

How about this?

  • Doppler Delay: delay gain = 5.0
  • Deadband Filter: thresh bias = 0.02
  • Ladder LPF: f0 bias = 3Hz, Q bias = 0


Which reminds me that I should probably create a simple single-pole filter unit because the full power of the Ladder LPF is not really necessary.


Yep, got there too, functions well without the deadband, and just the LPF

got it at LPF at 2-3hz all by it’s lonesome with 5-10x gain.

Thanks much @odevices


Awesome, now I can have my coffee.


Also getting nice smooth results with Deadband -> Ladder LPF.

And getting some freaky cool satellite transmission sounds with Deadband -> Slew Limiter. :joy:

haha yes, i’m pretty sure we’ve made contact :alien:


This is an interesting post and contains helpful techniques and details of unit use, so, as with other useful application posts I’ve bookmarked it for future reference, thankyou