Pedal Looper Overdub Clicks

Pedal looper normally get clicks on pressing the overdub button. Specially when My first recording is textures or pads, but also happen in other recordings. Is this a “normal” behavior? The clicks don’t happen on the loop itself (not a zero crossing issue) but when hitting “overdub”.

Overdubs are properly faded on punch in and out. Are you sure you are not clipping? Try putting a Limiter after the Pedal Looper to see.

It’s not clipping. And it only clicks in the precise moment I click overdub. The loop by itself doesn’t click, only when pressing the button.

That definitely doesn’t happen for me. Can you provide a video example?

Here it is. Please ignore that the audio is coming out only from the left side, as I was recording with a mono cable using only the left channel.


Could you please describe the patch and how you recorded the initial material or show a video of the entire process from an empty patch? I didn’t ask for a video just for proof of the clicking (I believed you when you say that you hear a click). I asked for a video hoping that I can have a better chance of reproducing your problem.

Also, what firmware version are you running?

I’m running the latest you’ve shared a few days ago (6.16?)

I haven’t tried yet In a “clean” channel, this was already on a patch. Will try later to replicate this on a blank patch but also send you the video and settings for the entire patch where this is happening.

1 Like

Ah, so there is a bigger patch around it. What is the CPU load? If you are at the limits of the CPU, engaging overdub might momentarily push it over the limit causing a dropout. Just a theory though.

I’ve quickly tried with a blank patch and that doesn’t seem to happen.

Didn’t yet had the chance to document the patch where that is happening but it’s essentially four parallel mixers with pedal looper on the first and 3 other feedback loopers. I did “replaced” the first feedback looper by the pedal looper. Each one of the mixers has a VCA after the loopers so I can control those with and external controller via TT using MidiOps. I think there may be some other stuff but not sure if they are bypassed or not, but haven’t touched those for the video.
The CPU load is 71% and seems quite stable.

Hey Brian, this is my current setup, items that are having the click problems are highlighted in red.
I’ve done this from scratch again but it keeps clicking.

I’ve also tried to remove all the other devices, keeping only the pedal looper but havent helped.
The only way I don’t get the clicks is when I start a brand new patch and add only the looper.

1 Like

FYI, still working on this:

Thank you Brian. Were able to replicate the issue?

any chance there’s a slight DC offset in the incoming audio signal?

@borbto Please try this (test) firmware to see if it fixes the problems with the Pedal Looper?


There are some problems fixed, but I’m not 100% sure I’ve reproduced and thus fixed your problem.


Thank you Brian,

Will try it and get back to you as soon as possible.

Back to you, just tested with the new firmware but the clicks persist.

Thanks for reporting back. Debugging continues…

Thanks for looking at it. Please let me know in case I can help with anything.