Quicksave failed to load

Hi all, I wanted to confirm a behaviour and check understanding which maybe a lesson to others. I got the “failed to load” quicksave error and lost a big patch. If I create a custom unit and save it and include it in a patch and quicksave that patch, do unsaved changes to the custom unit in the patch break the quicksave? ie if I work on a custom unit that is in a quicksave patch, do I need to save the changes to the custom unit prior to saving the quicksave.
I searched and couldn’t find this issue in another thread. Thanks

(I’m assuming firmware v0.3.25. Please let me know if this is not the case.)

  • May I please have the quicksave file for analysis?
  • Custom units that are saved in chain presets or quicksaves are fully encapsulated and are not links.
  • Most likely the quicksave failed to load because it was big not because of any “unfinished custom units.”

Ah thanks for clarifying. And yes it is v0.3.25. Unfortunately I overwrote the slot with the blank patch that loaded instead… but the change to the custom unit had doubled a looper and delay chain which obviously increased the CPU load significantly and I assume made it too large.
It would be good if a warning had come up. And is there anything that could have been done for if it happens again (assuming this isn’t dealt with in the new firmware)?
(Looking forward to exploring v4!)

I’ve been unable to load quick saves. I get the message: “preset version is incompatible with this firmware”. I’m on firmware 0.6.12 (stable). Anyone else experiencing this?

You’ve been using your ER-301 for awhile now so can I assume that you were loading quicksaves successfully before?

I just tried for the first time yesterday. I tried again today, and received the same message.

Where did the quicksave that you are trying to load come from? What version of firmware created it?

Also make sure you update to the most recent firmware which is v0.6.14 as of now.

I’m not sure what you mean. Where did the quick save come from? I received my 301 about three weeks ago, and this is the firmware version it came with. I will update to the latest firmware and try again this evening.

The error message means that the quicksave that you are trying to load was created with an older firmware. Hence, I’m asking how you got such a quicksave on your SD card.

Oh, ok. I’m not sure. I’ve only had this one firmware. That’s what was confusing to me also.

is the 301 second hand? perhaps the old owner left some quicksave made with previous versions of the firmware and then updated the firmware.
i have 0.6 installed but i still have quicksaves made with 0.5, 0.4 and even 0.3 versions. some of those quicksaves are impossible to load with the current firmware.

1 Like

Nope. Got it in the mail from Tokyo last month. All quick save slots were empty. I made a quick save, and titled it “1st Save”. I came back the next day and the title said “1st Save (Empty)”. I tried to load it, and received the message “preset version is incompatible with this firmware”.

Is it possible that you cut the power before the quicksave was done writing to the SD card? It looks like that quicksave slot is corrupted somehow…

As a test (after updating to v0.6.14) please try making a new quicksave, rebooting, and then loading it.

I think the quick save only took a few seconds, so I don’t believe that would be the issue. I actually made a second quick save in slot 2 last night, and the same thing happened in that slot also. I’ll try with latest firmware when I get home, and let you know.

Something I noticed was in the “Saving your work” portion of this tutorial (How to build a simple drum rack - O|D Wiki), it says to press S1 to save. When I pressed S1, nothing happened. So I pressed enter, and when I pressed enter, it seemed to save. Perhaps I didn’t save it properly? I’ll go through these steps again, it’s possible I didn’t actually save the work, only the name. After I pressed enter, it seemed like there was a significant saving process that took place, but maybe that was just saving the title.

I’m not sure if this will be helpful for a fix, but I had a similar problem in FW 0.5

I had to ‘physically’ rename the quick save file on my computer with Q01 for it to load again. I’m not sure if this is the same problem you’re running into on FW 0.6 though.

Here’s my thread with screenshots.

Good luck!

I just made another quick save after following the directions more closely, and I was saving it incorrectly. I pressed enter thinking I was saving the project, but didn’t realize I also had to press save after that. I’m a dummy. Sorry about that everyone, but thanks for the help and advice. I appreciate it!

2 Likes