Sixnon's Mysterious Crashes - Fixed

Thank you. I initially thought that the behaviour and that was what I was seeing with no slices in the sample i.e. if i loaded a sample it just kept looping within the sample player unless I added a gate, when it reset to the beginning and again continued looping until a gate signal. When I added slices, however, and triggered them using a keyboard gate they were stopping at the end of a slice. I shall look back over Neil’s videos and the sample behaviour thread to make sure I understand that behaviour better.

That is correct. The play head will stop at the next (or previous slice when speed < 0) but the player is still not paused. The play head is just blocked at the next slice waiting for a trigger. When there are no slices, there is nothing to block the play head so it just keeps playing and thus loops forever.

Ok, great, thank you. I’m much clearer on the function now!

I think I misunderstood what you meant by waveform scroll @sixnon. Do you mean it freezes in the file-browser screen (while loading samples in to the pool) or in the slicing screen (while editing slices)?

@sixnon, I went and created a separate thread for your crash reports because I’m having trouble reproducing any of them. :cold_sweat: Don’t get me wrong, I’m sure they really happened but I’m missing some crucial step to get them to occur on my test unit. This thread is my focused attempt to get to the bottom of this mystery.

So first, the SD mount crash: Do you remember what was the last thing that you did when it crashed? Were you moving the STORAGE switch from eject to admin/user?

Second, the crash while scrolling around in the AKWF sample tree: For now, I’ve been assuming that the crash happened while you were scrolling through the AWKF_0001 folder and previewing them. However, I cannot get that to happen. Am I at least on the right path?

Third, the crash while deleting slices: Since I believe there is no reason to be slicing the AKWF samples, may I assume that you were working on a different set of (non-wavetable) samples when this crash happened? May I know the properties of one such particular sample? Have you found this one to be consistently reproducible?

1 Like

Hi Brian,

Had a momentary cognitive disjunct when I spotted the thread there “was sure I didn’t do that!”.

I’ll do my best explain with the caveat that these all occurred in the heady first day or so of having the ER-301 in my rack, and I was excitedly loading units, pressing buttons etc., without too much structure;

I definitely wasn’t moving the switch during the process of the SD mount crash. I was endeavouring to load a sample into either the sample pool or a sample player. I pressed load sample and realised there was no SD card in the slot so pushed it in and the ER-301 immediately froze. As I’ve mentioned I’ve subsequently upgraded to 0.2.5 firmware and in an endeavour to reproduce the crash got a “SD card not mounted” notice (or words to that effect - I’m not in front of it at the moment) which was not apparent at 0.2.4 firmware…or at least not when I had the crash. As I say I’ve not been able to repeat the freeze.

The crash whilst scrolling the AKWF sample tree did occur as you suggest. It was either at a preview then scroll to next sample process or a scroll to next sample and preview process, if the distinction is clear? I noticed that @cfunk reported a very similar crash at the bottom of the V0.2.x-stable: Thank you! thread today.

Edit: and now this one as well.

You are correct there is no reason to be slicing wavetable samples…but alas I was! I hadn’t really registered the brevity of the samples when I went to try to replicate an earlier crash. Again this was after a firmware update. I had prior been working on much longer files (up to 30 seconds) but in that instance had (for some reason) pressed insert as I loaded the AKWF sample which then began to autoplay within the sampler and I continued with the process of deletion with the prior crash in mind.

Let me know if that’s not clear and/or if there’s anything else I can offer. I’ll try to reproduce processes this evening here. I have funeral to attend in a remote area of Australia and will be away from the ER-301 for a couple of weeks after Tuesday,

I can reproduce these freezes pretty easy, too. It’s been happening to me when loading custom units and loading samples in the sample player with a couple of single cycle libs I have downloaded.

Also : if you audition just once, and for a short period of time it doesn’t crash. It seems to crash when you audition for longer than one or two seconds. If you quickly load the sound it doesn’t crash. So the problem is on the playback in that module I guess.

Sorry if I’m being dense, but what do you mean by “these freezes”. It’s sound from your description that you are experiencing yet another problem that is causing a freeze when loading a custom unit from a preset? I do not think sixnon has reported such a thing yet?

So we can definitely say that we have a freeze associated with the auditioning of WAV files in the file browser. We can also probably say that it has nothing to do with the actual WAV file itself and just the act of auditioning one file after another is enough to cause it to happen. Does that accurately describe the problem?

I still don’t really have a solid handle on the conditions of the “insert SD card” crash and “delete slice” crash. I will of course keep trying various things.

@sixnon, there is no urgency here. Have a safe trip!

@odevices sorry for mixing up if I did. Yeah there seems to be a problem with maybe repeating very short samples when auditioning. This happens both with loading a custom unit from a preset and also if you load a single sample player and audition. The only samples I have tried a single cycle waves so that might be narrowing the scope of the bug ?

Let me know if you need more info, pictures or anything

Cheers

Thanks Brian.

I think that most accurately describes the freeze for me in auditioning. It’s been in the movement of one file to another that I most explicitly remember it. I’d go so far as to say I think it was more prominent if the file was being auditioned as the encoder was turned to select the next file.

The SD card crash happened only once.

The delete slice crash was definitely repeatable on earlier firmwares but I’ve not been able to replicate on my current setup. I’ll try to find a case in which I can and let you know.

Edit: I just loaded the AKWF files I referred to prior in an effort to replicate the kind of behaviour I mentioned above. No freezes BUT I loaded AKWF_0001/AKWF_0007.wav into sample pool (after some scrolling to try to elicit freeze) and then sample player. The sample auto played and I entered slice mode, pressed insert a number of times then pressed cursor/follow button. I then made a number of other slices at cursor position. I went into slice menu to have about 7 slices at the 0 point and two others further along the sample. (obviously the distinction is marginal as it is a very small sample). I deleted the slices and when I reached the final deletion the unit froze. I rebooted and tried to replicate but have been unable to.

It’s odd, and doesn’t necessarily make sense but the crashes seem to come in the first booting in the day and then difficult to repeat thereafter…not to add to the already problematically particular quality of “sixnon’s mysterious crashes”!

I was just wondering (and I’m sure you’ve considered this @odevices) if, given the sample was playing at the time of the slicing/deleting if this may not be just part of the audition bug, but on checking with the 0.2.8 firmware was again able this morning to replicate the slice delete bug with the above mentioned single cycle waveform file. I’ll try again with longer samples to see if it comes up again.

I don’t want to be THAT guy, but I’ve just returned to my office and fired up my ER-301. I loaded a new firmware onto my disting to test a reverb and ran a Mother 32 through that into a stereo pair on the ER-301. I recorded a sequence into a 30 second buffer using a Sample Recorder then deleted that and installed a Sample Player. I went into the Sample Player and, using the same buffer, inserted about 5 slices at various points. Not finding the result I wanted I deleted them all and inserted others. I had deleted about 3 of these when the system froze and needed to be power cycled.

Suffice to say whatever is causing my particular slice bug remains.

I had loaded the 0.2.9 firmware 0.2.9 at 48kHz prior. I’ve been pretty busy catching up after 2 weeks away and have only sporadically used the unit, but this was my first crash in 3 days use.

I tried to reproduce this bug, but i failed to.

Yes, that seems to be the consensus! Not sure why it persists for me.

Don’t worry, I haven’t given up on finding this bug. I suspect it is so hard to reproduce because it depends on timing. Despite my efforts to prevent it, there must be a resource contention when the sample player is accessing the slice list at the same time that you are trying to delete slices from it.

No worries, I don’t want to badger you, especially as it seems I’m the only one having the issue. Just wanted to let you know it’s still there and not necessarily related to short waveforms.

Have these crashes ever been resolved?

I’m pretty sure they all have;

delete slice bug here recently;

the others some time back.