Sixnon's Mysterious Crashes - Fixed

@odevices sorry for mixing up if I did. Yeah there seems to be a problem with maybe repeating very short samples when auditioning. This happens both with loading a custom unit from a preset and also if you load a single sample player and audition. The only samples I have tried a single cycle waves so that might be narrowing the scope of the bug ?

Let me know if you need more info, pictures or anything

Cheers

Thanks Brian.

I think that most accurately describes the freeze for me in auditioning. It’s been in the movement of one file to another that I most explicitly remember it. I’d go so far as to say I think it was more prominent if the file was being auditioned as the encoder was turned to select the next file.

The SD card crash happened only once.

The delete slice crash was definitely repeatable on earlier firmwares but I’ve not been able to replicate on my current setup. I’ll try to find a case in which I can and let you know.

Edit: I just loaded the AKWF files I referred to prior in an effort to replicate the kind of behaviour I mentioned above. No freezes BUT I loaded AKWF_0001/AKWF_0007.wav into sample pool (after some scrolling to try to elicit freeze) and then sample player. The sample auto played and I entered slice mode, pressed insert a number of times then pressed cursor/follow button. I then made a number of other slices at cursor position. I went into slice menu to have about 7 slices at the 0 point and two others further along the sample. (obviously the distinction is marginal as it is a very small sample). I deleted the slices and when I reached the final deletion the unit froze. I rebooted and tried to replicate but have been unable to.

It’s odd, and doesn’t necessarily make sense but the crashes seem to come in the first booting in the day and then difficult to repeat thereafter…not to add to the already problematically particular quality of “sixnon’s mysterious crashes”!

I was just wondering (and I’m sure you’ve considered this @odevices) if, given the sample was playing at the time of the slicing/deleting if this may not be just part of the audition bug, but on checking with the 0.2.8 firmware was again able this morning to replicate the slice delete bug with the above mentioned single cycle waveform file. I’ll try again with longer samples to see if it comes up again.

I don’t want to be THAT guy, but I’ve just returned to my office and fired up my ER-301. I loaded a new firmware onto my disting to test a reverb and ran a Mother 32 through that into a stereo pair on the ER-301. I recorded a sequence into a 30 second buffer using a Sample Recorder then deleted that and installed a Sample Player. I went into the Sample Player and, using the same buffer, inserted about 5 slices at various points. Not finding the result I wanted I deleted them all and inserted others. I had deleted about 3 of these when the system froze and needed to be power cycled.

Suffice to say whatever is causing my particular slice bug remains.

I had loaded the 0.2.9 firmware 0.2.9 at 48kHz prior. I’ve been pretty busy catching up after 2 weeks away and have only sporadically used the unit, but this was my first crash in 3 days use.

I tried to reproduce this bug, but i failed to.

Yes, that seems to be the consensus! Not sure why it persists for me.

Don’t worry, I haven’t given up on finding this bug. I suspect it is so hard to reproduce because it depends on timing. Despite my efforts to prevent it, there must be a resource contention when the sample player is accessing the slice list at the same time that you are trying to delete slices from it.

No worries, I don’t want to badger you, especially as it seems I’m the only one having the issue. Just wanted to let you know it’s still there and not necessarily related to short waveforms.

Have these crashes ever been resolved?

I’m pretty sure they all have;

delete slice bug here recently;

the others some time back.

Awesome - sorry to bring it up again, it’s just good to complete the thread with a happy ending… for reasons soon to be revealed :wink: