Swipe - Custom Unit for Whooshes SFX

Zeta, thanks for the heads up man! I’ll hold until the update (now I’m really excited!!!). Cheers.


New version at the start of the thread :wink:
Tonight/Tomorrow I will post a new video to show the features!


whoaaah! lotta new intriguing features! can’t wait to try the impact and live input!!! thanks!!!

1 Like

hello Zeta
you wrote the Unit Cpu Load is about 70% at 48khz 4.11,
when i load the Unit with no other Units at other Channels at all its still unusable, the lag so high every Encoder turn or button press react after 5-8 seconds, and CPU load is about 95% even when nothing is patched to trigger the Unit or other action. this seems not normal. Any ideas ?

@odevices i have noticed this with other Units that shared here too and i am wondering did you upgrade the CPU between the hardware Revision of the boards ?
On the 301 Webside is written hardware is revision 10, and as i am one of the first buyers i think mine must be 1 .

Just curious if you’re using the standard or low latency version? I assume the low latency version is more CPU intensive.


Definitely no CPU upgrade… everyone would be going crazy if this had happened :wink:

There’s something else going on!

ha good hint, i could swear i am on normal version but forget to switch back after testing low latency version.
Works normal on this one.



I would never make such a huge revision silently :open_mouth:

Here is a list of all revisions so far:



Glad you worked it out :wink:

I can’t get this to work - I loaded the impact sample, but couldn’t find the right way or location where to load the whoosh sample, can you elaborate please?

I don’t have the 301 in front of me so I will have to check tonight, but it should be as straightforward as digging through the containers called either “Swipe” or “Loops” then you should find A, B and C which are the 3 looping samplers. From there click on the sampler name and load a sample pool.

1 Like

I’m afraid you’ll have to be more specific…

Uuu nice panel! Drill into Loops

I’m also having a hard time getting this to work as intended. I was able to load samples to the correct locations but there seem to be units missing and from what I’ve gathered it’s only units from Joe’s accent library that fails.

I have them sitting in a custom folder - lib/accents and they work fine otherwise.

I just took a look through the unit preset with a text editor and there are no units in the accents library being referenced.

Where ever a unit is instantiated there will be this loadInfo table:

	["loadInfo"] = {
		["keywords"] = "utility, effect, source, custom";
		["category"] = "Containers";
		["title"] = "Custom";
		["moduleName"] = "Custom";
		["id"] = "Custom";
		["libraryName"] = "builtins";

The libraryName entry indicates which library the unit is coming from. In the case of the Swipe_0.2.unit they are all from builtins.

OK, I found a sample and randomized it a bit, but the Swipe control doesn’t do anything, the sample just continuously plays back…I think we need a short how-to video :slight_smile:

The ER-301 presets at the moment (as of v0.4.11) refer to all samples via an absolute path. So this means you have to have the samples in the exact same place as the preset creator.

Inspecting the *.unit preset file, I can see lots of paths like this:

["path"] = "1:/ER-301/_Waveforms/Ramp/Ramp_S2.wav";
["paths"] = {
[1] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_01.wav";
[2] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_02.wav";
[3] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_03.wav";
[4] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_04.wav";
[5] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_05.wav";
[6] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_06.wav";
[7] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_07.wav";
[8] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_08.wav";
[9] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_09.wav";
[10] = "1:/ER-301/ER-Swipe/Samples/Loops/Swipe_Loops_10.wav";
["path"] = "1:/ER-301/ER-Swipe/Windows/Window_R_Log1.wav";

(I just searched for the words Ramp, Samples and Windows.)

This tells you where the unit preset is expecting the (included) samples to be located:

Ramp: 1:/ER-301/_Waveforms/Ramp
Samples: 1:/ER-301/ER-Swipe/Samples
Windows: 1:/ER-301/ER-Swipe/Windows

FYI, 1:/ means the front SD card.

It is also not too hard to use search & replace to alter the paths more to your liking.


Okay. Sorry for the confusion, I must have mistaken something i read somewhere that indicated the use of the library on this custom unit.

This is exactly what I have been experiencing too, along with having to manually trigger each set sample once before they start playing.

Thank you, I will try this straight away and report back.

Everything works now after I placed the folder in 1:/ER-301/

Thank you for the help!

1 Like