Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Switches on ER-101

So i just received black faceplate from @paulstone (thanks!) and while removing the cover from the ER-101, the bottom right switch (hold, edit, follow) was so tight in there that it popped apart. I quickly plugged everything back in to test and fortunately it all works and is stuck in edit mode. All the soldering is still solid, it’s just the inner workings of the switch itself popped apart. I think i have all the pieces and can put them back together to hopefully get it fully functioning again, but could use some guidance on how to do that. Any ideas?

UPDATE: Well it makes a switching sound and toggles, but it stays perpetually in edit mode, which makes me think it’s just busted. Can I order a replacement switch?

@odevices do you have extra switches that I can purchase or do you know where I could purchase from?

So I was playing and everything was fine when my ER-101 suddenly stopped playing. It was just sort of stuck, so I rebooted my entire rack and when it starts up now it always just freezes saying 14-bit on the screen. If I disconnect the 102 it works fine. If I leave the 102 attached and flip the SD-card switch to eject, remove it and then put it back in and flip back to user, SOMETIMES it will correct itself and I can start using it normally. This just started happening today randomly and I’m not sure why. Halp!

Here is the part number for the switch: ATE1E-2F3-10-Z
https://www.digikey.com/product-detail/en/nidec-copal-electronics/ATE1E-2F3-10-Z/563-1763-ND/5086864

You can order from Digi-key or I can send you a few at the price that I pay plus shipping:

  • $3.50 per switch
  • $6 for shipping

For future reference (and this goes to anyone who is removing a panel on any module not just mine), never force a panel in such a way to put stress on components or the PCB. In this case, the switches on my modules have a friction fit which in some cases can be quite tight, so make sure to free the switch from the panel by inserting a flathead screwdriver (or similar) between the panel and the top of the switch body and twisting:

This way there is no stress on the component or the PCB.

I moved this here so that we have all the pertinent information in one place. The description of your problem points to some kind of physical or hardware issue which might be related to the trauma of the panel swap or something else:

  • What is the history of this ER-101/102 combination?
  • Did it ever work? In other words, were they working fine together before the panel swap?
  • Is it 2nd hand?
  • Did it come with an SD card? It might be useful to test with another SD card.
  • Was the expansion cable ever connected to power by accident?

Thanks for the link to the switch, I just ordered.

I bought the ER-101/102 used on Reverb about a month ago and it arrived about 3 weeks ago. The original owner had it updated to the latest firmware, didn’t ship the 102 with a memory card, and had replaced the faceplate on the 101 previously, and included the other faceplate with it. When I first connected everything the 101 and 102 didn’t work together due to there being no memory card. I ordered one, disconnected them and used the 101 on its own with no problem for several days. I then got the memory card, put it in the 102 and used them both together for a while with no issues. Several days ago, I received the new panel in the mail.

I removed the 102 first and attached it to the new combined panel without issue. When I removed the panel from the 101, the switch was really stuck. I tried to be as careful as possible, but everything got sort of stuck and I honestly think that the ER-101 may have been dropped by the previous owner and the switch was turned slightly off center, which forced the issue of it popping apart when I was trying to remove it all.

When it flew apart, I thought “Oh my god I broke it” but I plugged everything in and it worked, stuck perpetually in Edit mode.

This was working fine for several days until today, when I was working on a track I’ve been playing around with and all of a sudden my Pamela’s New Workout that was serving as master clock to the ER-101 suddenly stopped and the tracks playing from the ER-101 stopped. I clicked around the PNW with nothing and then just turned off my rack and turned it back on. After turning it back on the ER-101 stopped at saying 14-bit on the screen and then just kept rebooting. I pulled out the card put it back in and it started working again. But now everytime I start it up it does the same thing, and I have to move the card switch on the 102 to REMOVE, Remove the card and wait a second for it to continue booting, then I can put the card back in, flip it up and load a sequence.

Could something on the card be messed up? I looked at the files on it but didn’t see anything corrupted.

Also of note, if I disconnect the 102 entirely from the 101, the 101 works fine on boot.

Alright. It appears it is something wrong with the memory card. If I put in another one on boot, it doesn’t have this problem.

I confirmed it was the card. New card used today. Copied data from old card to it and no problems. So not corrupted data, just something with that particular card (that works with other devices and works once we are booted on the ER-101, but doesn’t work all the time).

Hmm, it sounds a little like the your case could be current-starving the ER-102 during start-up. Different cards require different amounts of power to operate. Just a guess from afar though.