Syncing a loop to a clock in v0.3

I think you need to either:

Prepare your loops so they are in the bpm your clock is running at

Or, slice each individual hit and not worry about syncing at all, just trigger with multiple trigger inputs.

Other than that the only way I know of is to do the time stretching as described here and in the linked to threads:

There may be other ideas… :slight_smile:

slicing individual hits really amounts to something entirely different. you’re going to lose the feel of the original loop that way.

i really feel like time-stretching beats to an incoming clock seems like a pretty common use-case for the 301 and it ought to have a very straightforward workflow to get there without dealing with manual grains.

You’re right, lets see what happens :slight_smile:

Oh… I presume you have just tried editing the speed of the sample playback?

If you pull up the scope view while editing the speed parameter so you can see when the trigger resets the sample playback, it’s not that tricky to dial in the right speed setting to make a single trigger at the beginning of the slice play the whole loop, or a sensible portion of it, in time.

i think dialing it in is not a good solution. i mean its a sound computer!

we’re talking about the most powerful sampler in eurorack… being able to lock a loop to an external clock without futzing around with the speed dial on a sample player feels to me like it should be a core feature. what if i’m in the middle of a jam and i decide i want to increase the speed on my master clock a little bit? i have to go and fine tune my sample player again? that just feels beneath the power of the 301 to me.

Sure, but that’s asking a lot:

So, on the fly at a whim, probably not. edit: I just realised I have linked to something that includes pitch shifting too and that may not be something you are concerned about.

I do see a possible solution in using the incoming clock to derive a voltage that could be scaled to set the speed parameter, but that sounds like a pretty tricky thing to set up.

With planning you could use a sequencer with a very slow progression to program changes to the speed parameter that would naturally fall in line with your clock, this is probably the best solution I can think of.

1 Like

yea i don’t know… it just seems like really meat and potatoes functionality for a sampler.

meanwhile, i tried to do the old manual grains technique with the new pulse-to-hertz unit setting the frequency of the sawtooth ramp, but it doesn’t really work… not sure what the gain on f0 is meant to be set to, but with the knob set to fine, the lowest gain i can get is 2.0 and it sounds like its at least twice as fast as it should be. maybe 1.0 is the right setting, but i can’t set it to 1.0 :confused:

1 Like

Did this not help?

1 Like

Also, be sure to understand how the internal values work, here’s a great place to start:

1 Like

that is from before the “pulse to hertz” unit. the method described in there involves calculating based on a known bpm.

pulse to hertz is supposed to give you the frequency based on an external pulse/clock so it should theoretically save you from having to do any calculating.

Ahh okay, I haven’t used that yet… regardless i think you hit the nail on the head with the gain staging setup!

Have you tried this?

  • Load your loop in to a Grain Stretch unit, with How Often? = loop and How much? = all.
  • Set the speed bias to zero and the speed gain to 1.0
  • In the speed sub-chain insert a Pulse to Hertz unit.
  • Set the source of the speed sub-chain to your 1ppqn clock.
  • Set the source of the trig sub-chain to your sync signal (once per loop).
2 Likes

Don’t forget the shift + encoder in fine is super fine adjustment - Brian showed me that yeaterday

just gave this a shot… i have the same 1ppqn pulse triggering a one shot kick sample and feeding the pulse to hertz unit.
the drum loop is definitely not in sync with the kick drum. tried with a few different loops of different bpms, and got similar non-sync’d results.

also, am getting some very mixed results with the trigger on grain stretch. sometimes it doesn’t do anything.

edit: ah… trigger doesn’t work unless there is a slice on the sample? this is confusing.

Did you see the first step?

  • Load your loop in to a Grain Stretch unit, with How Often? = loop and How much? = all.

definitely did

Then slices are ignored. A trigger should definitely be resetting your drum loop to the beginning.

i’m running v.03.0 so i’m gonna update right now to make sure its not a fixed bug

That’s a good idea. In general, if you are going to be using the unstable firmware then you will want to make sure to have the latest one.

v0.3.02 CHANGES

FIXED: Preamp Settings > Crash on load/save preset.
FIXED: Grain Stretch + Sample Player > Not responding to triggers in some modes.

1 Like