Track link/merge bug?

Took delivery on my ER-101 (Nostalgia, v2.07) a little over a month ago, and have been immensely pleased with its utility in my work.

I have run into what appears to be a persistent bug a couple of nights ago, and spent last night trying to figure out whether it was user error, to no avail.

(Apologies if I should be submitting a request for bug squashing in a different place; I’m new!)

Here’s the setup. I load a snapshot that I have been working on that contains the following:

  • a modulated chord sequence written in track 1.
  • a melody written in track 2.
  • a bass line written in track 3.

I unpause the snapshot, and hit the reset button. Track 1 and 3 play as intended, but the outputs from track 2 are identical to what is coming out of track 3.

At this point, if I focus track 2 in Follow mode, it shows the performance information that was written in track 3.

The sequence plays through what is written, and at the point at which it should start over, track 3 starts playing the sequence that is written in track 2.

At this point, if I focus track 3 in Follow mode, it shows the performance information that was written in track 3, followed by the performance information that was written in track 2.

If I focus track 2 and enter Hold mode, I can sometimes see the track 2 information, followed by the track 3 information. If I delete the track 3 information by step from the track 2 focus (which incidentally appears as pattern 2 after track 2’s pattern 1), it also deletes the track 3 information from track 3. If I delete the track 3 information from track 2 by deleting the pattern, the device hangs and requires a power cycle to unfreeze it.

I’ve power cycled numerous times, tried deleting all of tracks 2 and 3 and re-entereing them, tried saving the snapshot to another location, and even deleted other snapshots (in case it’s an issue of running out of step/pattern space), and have seen no improvement.

My hope here is that it is user error, because I would love to get back to using this fantastic tool, but I’m out of ideas for what the root cause might be and am pulling my hair out. Any help would be greatly appreciated!

Welcome. You are posting this in the correct place!

By any chance, do you recall what you approximately did when this behavior first appeared?

Here is what I would like you to do:

  1. Install the ER-101 Programmer on your computer.
  2. Follow the instructions to connect from the Programmer to your ER-101 via USB.
  3. On the Programmer > Snapshots tab, choose Destination File and then press the “download” arrow. This will save all of your snapshots to an XML file on your computer.
  4. Next, go over to the Firmware tab, and check the “Clear snapshots” box.
  5. Select v2.07 from the “Select Firmware” list.
  6. Press the “upload” arrow.
  7. Disconnect and place the ER-101 back in your case and test again.

Please send me the XML file that you created in step 3 for analysis.

Hey @odevices,
Tanks for getting right back to me! Firmware is reflashed (interestingly, the ER-101 Programmer saw my ER-101 as having v2.06), and we appear to be back up and running! I will be sure to follow up if I experience any additional issues.

Excuse my not knowing; where would I send the xml file to you?

Thanks again!

You can either reply to this thread and drag-and-drop it into the edit box, or, you can attach it to a PM if you prefer to send it in private.