Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Track-specific user transition of Parts not working

Hey all,

So I had a cause to give this a whirl. Here’s a quick rundown:

  1. Setup the config.ini for Track 4 to be my transition track. I typed “Track-4” in the config.ini

  2. Had the clock divider on Track 4 enabled to divide by 4.

  3. When I set up my parts (all included start, end, and reset points), I tried the below both with Track 4 included in the parts and not included.

So with the above setup, when I go to transition to a new part, the part just stays as pending (light flashing next to parts display) without transitioning when track 4 loops around.

I also tried this with Track 3 and still did not get this to work…On the plus side, if I set the user transition to FOCUS, it does indeed work…but this means I have to make sure I’ve selected Track 4 every time I want to transition.

Can someone explain if I’m doing anything wrong from what I’ve described?

Thx in advance.

Have you tried a small delay on track 4 transition gate.

Hmm…well so far I’m just trying to trigger the transition manually via the transition button on the parts section of the 102.

It’s my understanding that if a specific track is set to the user transition, the timing of that track should determine when the activated pending part begins?..not necessarily the gate settings on the track itself…is there a way to adjust the delay on the gate setting the timing of the transition internally?

I don’t use 101 tracks to sequence parts. On page 9 of the manual, bottom image, the cv part select occurs before gate activation.

I see what you’re saying, but I’m NOT using Track 4 to sequence the parts.

There are three settings for how parts transition from one to the next: First, Last, and User. This setting is an internal one which governs at what point a currently selected part is transitioned to once that part has been activated. This holds whether the part is selected and activated manually or whether by another source (like a track on the ER-101. i.e. sequenced).

So when a gate is received at the parts activate input or by pressing the transition button, that transition begins so to speak…and the config file lets you pick the User transition…one choice being a specific track on the 101. So track 4 isn’t sequencing the parts but more determining the timing between the parts whether sequenced or manually controlled…and I can’t seem to get that to work given the above setup.

When a part is activated, it just seems to stay as pending without switching…it’s like nothing is there to transition the parts when the User transition is set as a 101 track…it’s a head scratcher at least for me :thinking:

Thanks for the assist though! It keeps me thinking about it :+1:

i remember that brian implemented this track specific part transition based on my request and it did work perfectly back then, but i just checked and somehow this doesn’t work anylonger, maybe it got broken with a recent update?
but when i press transition (and have track1 as user transition defined in the config file), my transition doesn’t wait until track 1 has ended, it transitions quite immediate, but quantised to the clock. i think that’s a transition type as well, so maybe there is a weird mixup in the config file?

but i can’t replicate what @vzvision says, that the transition is pending forever…
is the part led blinking all the time @vzvision?

i hope brian can replicate these problems and fix it!

Oh, maybe this is why I don’t really get along with parts? I thought it was me not really getting it when it gets more complicated. Has @odevices seen this then and has a chance to look at it?

@vzvision I can confirm this bug. The bug is that the actual track used is off by 1 from the configured track. So for example,

user-transition = track-1 

will cause track #2 to be used and so on.

What is weird is that as far as I can tell it was always off by 1 like this. I will have it fixed in v2.25.

@kilchhofer I think the behavior you are seeing (i.e. immediate transitions) is due to non-ASCII characters being introduced into your CONFIG.INI file? This would cause the ER-102 to not recognize your custom setting and thus default to:

user-transition = immediate
3 Likes

thanks for replying brian…
ha! that’s weird, i definitely remember the “it works” feeling after you @odevices added this feature…maybe some kind of placebo effect made me satisfied and not realize this bug… or maybe the parts were the same length…

i use the simple text editor on a mac to change config.ini settings, do i need to save it in a special way?

Awesome! Thanks Brian.

Was going to roll back my 102 to 2.22 where this feature was added but sounds like waiting will be best :+1:

@kilchhofer It very well may have been that your muscle memory of making sure tracks across parts conform to the same length meant that the user transition between tracks was the same :smiley:

Will give “Track-3” a try in the config.ini next time I’m back at the modular.

Many thanks again for the assist.