Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

Troubleshooting ER-101 that doesn't seem to get power

I purchased a used er-101 that likely has a short circuit or similar issue and I’m trying to troubleshoot what’s going on. When I first gave it power, it powered up for a couple seconds then shut off and won’t turn back on. I’ve checked power (busboard with shrouded headers), the module doesn’t have an electric burning smell, and I’ve even tried to connect with the USB to the O|D programmer and nothing is working.

When I plug it in, the module just appears not to get any power and shows no indication of working

While I am talking to the seller about what’s going on to resolve the issue, is there anything I can do to help troubleshoot this issue?

A high resolution picture of the rear of the ER-101 might help identify some issues.

Thanks for the quick response @odevices Here are a couple photos (1 in this message 1 in the next) of the back of the module. Apologies if there is any funny lighting. Let me know if you need other photos to help troubleshoot.

Thanks!

Second photo

@odevices Update ~24 hours later:

  • I managed to get the ER-101 to turn on again today and have it both working in the rack and managed to get it connected to upload the new firmware
  • During the first attempt to update the firmware, the module did seem to randomly turn turn off/disconnect from the computer (see the snapshot of the logs below to give an idea of the timeline)

Right now, it seems stable and working, but I’m concerned it will have continued seemingly random shut-offs/power problems. But I’ll keep monitoring in terms of what’s going on.

Logs for when the module disconnected/turned-off:

22:58:05.0993 INFO STATUS Connected to the ER-101.


22:59:30.2166 INFO Working Directory: /Applications/er-101-programmer.app/Contents/MonoBundle/Resources
22:59:30.2169 INFO Executing: /Applications/er-101-programmer.app/Contents/MonoBundle/Resources/dfu-programmer at32uc3c1512 erase --suppress-validation
22:59:30.2259 INFO dfu-programmer (O|D flavor, v1.1)
22:59:30.4010 INFO address top: 7ffff
22:59:30.4016 INFO address bottom: 0
22:59:30.4022 ERROR dfu-programmer: no device present.
22:59:30.4254 INFO Execution is finished.
22:59:30.4257 ERROR Failed to erase the device.
22:59:30.4261 ERROR STATUS Failed to erase memory.


22:59:49.9533 INFO Working Directory: /Applications/er-101-programmer.app/Contents/MonoBundle/Resources
22:59:49.9533 INFO Executing: /Applications/er-101-programmer.app/Contents/MonoBundle/Resources/dfu-programmer at32uc3c1512 dump “/Users/XXXX/Library/ER-101 Programmer/dump.bin”
22:59:49.9755 INFO dfu-programmer (O|D flavor, v1.1)
22:59:50.1274 INFO address top: 7ffff
22:59:50.1274 ERROR dfu-programmer: no device present.
22:59:50.1282 ERROR address bottom: 0
22:59:50.1749 INFO Execution is finished.
22:59:50.1752 ERROR Failed to download from device.
22:59:50.1754 ERROR STATUS Failed to connect to the ER-101.
Is your ER-101 in DFU mode?


The Er-101 is back to being unresponsive (though there is a quick LED flash to show it is at least getting some power).

@odevices Could you PM me to set up a repair? I’m guessing there is something with the power/voltage circuit since everything else seems to work when it gets power and likely caused by a bad PSU unrelated to the module/your build. Can provide some additional specific details to help troubleshoot through messages.

Some questions:

  • Which setting are you using for the 5V source? REG is recommended.
  • If using REG, is the 5V regulator (above the 5V source switch) hot to the touch?
  • During an outage, what are the voltages that you measure at the test points next to the power connector? (5V, GND, 12V)
  1. I’d been using BUS primarily (except for when trying while USB connected)
  2. Just tried REG and it does get hot to the touch. Usually takes a few seconds to “heat up” but it is noticeably hotter to touch than other chips
  3. +12v is getting ~12 (what I had been normally reading from the busboard); GND is getting around 0, and +5v is getting around 1-1.1

That sounds like your ER-101 was damaged by having a power cable connected to the expansion port. The MCU is probably running very hot. You can try touching it but be careful.

Most likely, the MCU will need to be replaced.

1 Like

Thanks for that diagnosis/troubleshooting!

What’s the best way to get it repaired? I was told the module wasn’t purchased directly from you, but from a retailer in the US. So I’m assuming I’d have to send it over to you.

Hmm. Sounds like this module has had a colorful past because 1) I’ve never used any retailers in the US and 2) your module was initially sold to a customer in France.

I will PM you the instructions for sending a repair.

1 Like