V0.2.x-stable: Thank you!

Definitely noticed that previewing samples sounds grainy AF compared to normal playback. Not a subtle difference.

Okay! I finally reproduced and found the auditioning bug (knock on wood). :tada: Apologies for the delay, it was a hairy one. Many thanks to everyone who stepped up and provided detailed bug reports!

v0.2.8 CHANGES

FIXED: Occasional crash during WAV file auditioning (due to race condition).

6 Likes

Weird thing: 2.7 was giving me a bitcrushing effect on samples that were pitched lower. Seems resolved in 2.8, but I thought I’d mention it anyhow.

many thanks on the updates Brian, I’m glad I could contribute to your amazing work somehow!

Thanks for the fix Brian !

Screenshots are working now! This will help speed up documentation writing immensely. Might even help with bug reports? :nerd:

v0.2.9 CHANGES

  • ENHANCED: Take a screenshot anytime using SHIFT+CANCEL. Images are saved to the ER-301/sc/screenshots folder.

17 Likes

JK. Pretty sweet, though.

Brilliant!

v2.9 @ 48K

Different thread, but someone was asking about chorus so I thought I’d try building a weird variation by slowly modulating the start time of 2 Grains units.

Basically a shared buffer situation with one writing to it, others (grains) reading from it.

Either a live feed from an input to a Looper or Sample player feeding a looper with a 200ms buf1 file.

Chain feeding out1:

Mixer 1:

  • Grains unit assigned to buf1. Trigger: [SIN @ 25Hz] Start [.5 bias 1.0 gain - 1Hz SIN unit] Duration: 100ms

Mixer 2:

  • Grains unit assigned to buf1. Trigger: [SIN @ 25Hz] Start [.5 bias 1.0 gain - .295Hz SIN unit] Duration: 100ms

I’m hearing sporadic audio glitches - almost like a resampling / bitcrushy sorta sound. CPU usage is hovering around 25%.

Tests that didn’t appear to make a difference:
-numerous looper fade settings
-grain trigger speeds
-tried larger buffer lengths (i.e.: 1 second) Glitches less but it’s still there
-makes no difference if these mixers are within a custom unit or sitting on a primary track/chain

If I punch the looper out of record so it’s only looping the audio in the buffer, the glitches stop. So it would appear to have to do with writing to the buffer while others are reading from the same file simultaneously. I’ve previously used this shared method to manipulate incoming audio and it’s been pretty solid. Has something changed? The Last OS I had on the 301 before getting back from vacation was v0.2.5

I have a short little video of the sound if that helps?

Unrelated Custom Unit Bug:

It would appear Bypass still doesn’t work for units sitting on the main chain level of a custom unit, but works for units sitting within a mixer within the same custom unit.

1 Like

I found a funny bug last night. Reassigning the same sample multiple times seems to lower its amplitude in the Manual Grains unit. I haven’t investigated the other samplers.

-Create a Manual Grains unit.
-Add only one sample to the pool. (You can add more, but this is easier for testing)
-Assign the sample to the MG unit.
-At this point, I had a 16-20 Hz clock triggering the MG unit.
-Open the Assign Sample screen, and select the sample that is already being triggered.
-Repeat multiple times. The perceived amplitude of the audio should decrease each time.

1 Like

Thank you, @trickyflemming. Bug confirmed. It appears that when one reassigns a sample to Manual Grains not all of the active grains are properly retired and recycled into the pool of free grains. This tricks the Manual Grains unit into thinking that more grains are active than there are in actuality thus causing gain compensation to under-compensate. Anyway, this will be fixed in the next release.

1 Like

Thank you @NeilParfitt. I’m looking into this one but don’t expect a quick fix because it is likely to be quite a complicated fix. The glitches that you are hearing is almost certainly the granularization of the discontinuity caused by the Looper’s record head in the audio buffer. Each unit process its audio sequentially and in blocks, which would imply that in certain scenarios a play head and a record head pointing to the same buffer but controlled by different units might end up playing leapfrog.

3 Likes

Gnarly!!! God luck with that one :heart_eyes:

4 Likes

Hi Brian,

Running into some pretty heavy artifacts with the pitch shifting delay if the speed setting is >1 and <2, >2 and <3.

Has a sound quality similar to a sample rate reduction plug-in.

(v0.2.9 @ 48k)

Have you ruled out the nature of your input signal? For example, can you get the artifacts when using a sine wave as the input?

Also what are you doing with the delay time?

i’ll check again when at it - but the source was an internal SIN Unit being controlled by an arpeggiator. The delay time was just a set value, not being modulated. I’ll get back with some exact info.

I just tried the same thing (minus the arpeggiator) and it sounded right to me. There is a metallic quality due to the granularization but otherwise sounded fine.

One sec, I just realized I was testing in 96kHz. Tried it again with 48kHz and there are some quiet (but noticeable) aliasing artifacts. Is that what you mean?

(Really should get WAV file uploads working here…)

You mean uploading wav to the forum?

can confirm also experiencing this shift in amplitude with Grains when multiple destinations using same buffer (also with Looper) including the occasional zippering/glitch.