V0.2.x-stable: Thank you!

The “Space for Rent” over the S3 button in the Add Chain commands is slated for this. For now you can insert a mono or stereo chain and then dive into the newly created chain to access its Load Preset command.

The Load Chains command is actually for loading a previously saved set of global chains. Probably should rename this command to prevent confusion.

Just wanted to say thanks for this wonderful device and the continuing work on the firmware; it is exciting to watch it grow and explore the possibilities with each new update.


That might be weird - as the chain would be a “true ghost in the machine” if it’s out of the master list but still feeding chains, but unaccessible or tweakable.

I figured this - was just testing and seeing what was allowed (or not).


Whenever you have a chance… I have some non-pressing curiosities about some various scenarios…

Assuming i can do things such as:

  • Having a channel chain with nested custom units that tap global chains

  • Having a global chain made of a custom unit, that within is tapping off a source from another global chain

  1. Complexity of such scenarios aside, if i rename this global chain and it’s assigned across the system - will these assignments all safely update wherever they’re assigned or will it ‘break’ the connection???

  2. What happens if I save a channel preset that’s relying on global chain… will it load that as well or do i always have to have those saved as well?

  3. What happens if i have existing globals chains, and i load a new channel or chain preset that’s referencing a DIFFERENT set of global chains that happen to be named the exact same thing? Will it remap to the wrong (but matching named) global chain(s). I noticed that you can’t have a duplicate name so…

It would be pretty sweet to be able to merge in additional presets vs. overwriting existing… especially with more complex sessions where a user might want to introduce something pre-designed.

Last low priority question of the night - and this is probably a dumb one, and I’m assuming the answer is no:

  1. With these global chains, is it possible to create a bus to directly feed its input from an chain output other than via out1 to 4? I’m fiddling with ways to i.e.: have a samplelooper/grain setup in the global area acting as a global verb… but i don’t think i can feed it unless I use an OUT1 to 4 or INABCDG if I’m thinking about these correctly. A Bus Unit that could pass audio through to the out of itself, with a modulatable Level control that could be assigned to trickle an assigned global chain input would be incredible!!


Unrelated BUG
-The Ch. Mixer Unit Subchain scope on the smaller screen draws waveforms out of bounds and covers up the S1 text.

Unrelated Thoughts
-The Quicksave S1 “save” operation could benefit from an “are you sure Y/N?” prompt if saving to a slot with pre-existing data

-Wondering if the Global chains should be the first thing in the Admin list, as that would be the most frequently visited option after an initial channel setup?

-perimeter lines in the admin/global chains area are solid lines vs. the newer look of the channel area where it looks almost 50% brightness.

-duplicate Global chain names would auto add a ‘#2, #3 etc’ in the same manner as duplicate unit names. That, or maybe an admin preference for the fun auto-random name generator until you know exactly what you what your global to be :wink:


Naming Quicksaves is working but I cannot seem to switch between quicksaves now. When you go to load a different quicksave than the one that is currently loaded the 301 just says “removing units” and gets locked up.


While scrolling through .wav library after “assign sample” on sample player unit, the ER-301 freezes. Only a hard reboot can bring it back to life …

hmm… i’ve been trying various combos of this and can’t get mine to crash. With or without Global Chains in the setup.

Anymore info on the type of setups you’re running?

thanks for taking a look on your end Neil but still having the same problem here after just messing with it some more. i have my 301 set to prompt to ask if you would like to load the last quick save when booting up. tried “yes” and “no” thinking that might lead to a different result but no such luck. i have 5 quick save slots and sometimes you can open a slot with no problem and then another time it locks up when “removing units” to load the new quick save. will keep troubleshooting…

I am not sure if this is the place to reference a possible bug, please let me know if it should have it’s thread. Caveat, I’m very new to the ER-301, have searched the board for evidence of this, and it looked very much related to this;


I’m also in the process of finding my way around, as the UI has changed since Neil’s early videos, so I can’t be certain of exact button presses, but it occurred a number of times that in Sample Player I deleted all slices and the entire Er-301 froze, switches also non functional. A reboot via rack cycling fixed it. In an effort to recreate it I notice that there is no distinction between cursor and follow mode i.e. in both cases slices are dropped at cursor position. Engaging cursor mode simply means cursor moves to playhead and stays there. This may be expected behaviour?

I haven’t been able to recreate the freeze after the first 3 occasions.

I’m on 0.2.4 firmware 48kHz.

Ive tested this bug a couple times and have managed to make the 301 freeze every time. in a mixer channel with no other units I would assign an audio input, followed by a looper. I’d record to a buffer and assign that buffer to manual grains immediately following the looper. I spent some time playing with the buffered sample and when I delete the looper unit the manual grains would continue as though the looper were still working and when I would delete the manual grains the audio will pass through except now the manual grains unit is still displayed and the unit is now frozen.

the sound would still be coming from the grains, as when you delete the looper the assigned buffer in the Sample pool is still being used by the grains unit for sound generation. ill try your steps here and see if it’s 100% repeatable.

How big was your looper buffer?

It was a 5 second buffer.

Just managed to crash it clearing a chain, it was a looper placed before manual grains sharing the same buffer, 6 seconds i think it was.

I’m back and I will be looking at all of the recent reports in detail. Thank you everyone for these bug reports!

The timestamps on the 6-track recorder are not being created properly. Everything has “12/31/2013 11:00 PM” as the date created when loading the MicroSD card into my Windows 10 computer.

I also want to bring up a bug/feature request from 0.1.6: V0.1.6pre: volunteers needed:

Takes would be appreciated. More importantly, there shouldn’t be a “file saved!” message if nothing is saved/overwritten.

Unfortunately, there is no battery-backed clock on the ER-301 to generate accurate timestamps. Maybe on a future CPU board replacement!

Thank you for reminding me about this one!

1 Like

14 posts were split to a new topic: Sixnon’s Mysterious Crashes

I’m getting pretty consistent freezes with 2.5 when I switch from one saved Chain to another. They aren’t super-complicated chains. Just various a sampler, VCA, aDSR, etc…

I have a stereo chain setup on 1-2, that is just playing back a sample, and it always happens when I go to switch the chain on channel 3. I used to be able to swap chains on other channels while a sample played on the others…

Do you mean it freezes when you are loading a chain preset?

Yes. Also, it freezes when I just try to clear a chain preset. Displays message “Removing Units”…

1 Like