V0.3.23 reboots when changing System Setting

Can someone confirm this ‘bug’? Tested on both 48 & 96khz of v0.3.23,

When changing any setting in System Settings, after a short pause, my 301 automatically tries to save to the rear card (the message appears) at which point it freezes until I press a button and it reboots.

This also happens when you press Enter on a system setting option.

With older firmware (I checked on 3.18) , it looks like the system setting change was saved when you came out of the menu.

EDIT: just to add - after the reboot, whichever ‘setting’ I changed does appear to have been changed, so the save is happening (so I don’t think it’s caused by a corrupt rear SD card).

I’m not reproducing on 0.3.23-stable 48k.

It seems to be following the behavior you describe for older firmware. When I “up” out of the system settings, I get the modal indicating that it is saving to the rear card.

I tried changing GUI animation speed and displayed value for control readouts. No reboot. Any other particular setting I should test?

After a bit more testing… If I wait a bit longer before hitting the Up key, it actually doesn’t reboot but seems to lock up on me. I have to power cycle to restore. If I hit Up fast enough, it all seems OK. Something definitely seems amiss here.

And after a little more testing, another time I tried changing a setting and just did one up (to get back to settings). Waited a few seconds, and it saved an all was fine. Seems a little hard to produce a consistent result.

In my case, all the testing was done from a fresh boot - nothing else going on.

1 Like

Can confirm reboot behaviour here on V0.3.23 48kHz

1 Like


1 Like

Reproduced and fixed. Thank you very much everyone!