V0.3.x Firmware Workout: Better late than never

thanks @odevices!

<3 thanks @odevices ! this creature gets better and better!

Woohoo!!!

1 Like

legend thanks @odevices!

Woo! :ok_hand:

:bowing_man: Emergency fix! :bowing_man:

v0.3.24 CHANGES

  • FIXED: System Settings > Crash when autosaving the system settings.
  • TEMPFIX: Teletype Integration > Added i2c addresses 0x31 and 0x32. Will remove conflicting addresses in v0.4.
4 Likes

Got a bug, mono global chain mapped to both inputs on stereo global chain, is not loaded to right input on stereo chain when the patch is reloaded from a quicksave.

to test:

  1. Create global two chains, one mono and one stereo.
  2. Map mono chain as both left and right input on stereo chain.
  3. Save quicksave
  4. Reload quicksave.

This is on version 3.22

(v0.3.24) On all of the Delay units, increasing Feedback past max goes to “nAndB” and snaps to bottom of slider. The unit must be deleted before the signal returns.

1 Like

Darn it! Looking into these. :bowing_man:

3 Likes

I can confirm this one!

Sorry for the wait. These both turned out to be head-scratchers. :dizzy_face:

v0.3.25 CHANGES

  • FIXED: All delay units > Feedback parameter turns to NaN when dialed all the way up on 48kHz firmware only. The delay unit stops producing audio once this happens.
  • FIXED: Global Chains > Right channel of stereo global chains were not being restored properly from presets and quicksaves.
7 Likes

Hello! First I want to sat that this 0.3 versio is really cool! Super cool features…

But I have problems when I am trying to save chains.

FIRST: I did channel chain (with samplers etc.) and saved it in the card (filename 1+2.lua) and everything went fine.
BUT THEN: I did another similar channel chain (it was for channel 4) and saved it (filename 4.lua) BUT now when I am trying to load the chain 301 says that .LUA is not valid extension?? So why the extension is .LUA and not .lua?

Is there some problem in the firmware or what I am doing wrong?

Also I cannot load any of the old chains (–> same error message)

it is same in both versions 0.3.24/0.3.25 (48kHz version)

On the download page I took the time to read through the list of fixes, enhancements, and new units distributed across the 26 updates in this 0.3 cycle and am astonished that this was all accomplished over the previous six months.

This incredible opportunity to watch and influence the evolution of a module I think is unique in the history of Eurorack, add to it that the development, manufacturing, customer service, and coding is all done by one person and I can’t help but be moved to astonishment.

I’d guess that within the next two to four weeks we’ll see the first iteration in the v0.4 cycle at which point the delirium of novelty may push me to a kind of innovation drunkenness.

Thanks Brian for this Herculean effort.

6 Likes

Are you saying that your filenames were:

  • filename 1+2.lua
  • filename 4.lua

or

  • 1+2.lua
  • 4.lua

May I have an example of one of your old chains please? Also, the above files while you are at it.

You are VERY welcome. Although there are times when I would love to redirect a river through my workshop. :laughing:

7 Likes

i solved the .LUA vs .lua problem just copying the .LUA to my computer, duplicating it, renaming it and loading it back into the sd card. it did the trick.

Here is link to a folder where those files are…
https://drive.google.com/open?id=1ftBpCWSinUAm7ujM35O5HAHpAJTkIKgs
1+2 is working but 4 and 04 does not

and if this helps:
CHANNELS 1 & 2 are linked
Channels 3 & 4 are mono channels…

/////////////////////////////////////////////////////////////////////
And example of old chain which is not working is: 0001_2

//////////////////////////////////////////////////////////////////////

In this image you can see those crazy extensions ???

I tried this but it did not help… Also in my computer the file extensions are .lua only 301 shows them .LUA ??

yes, same thing here. only the 301 sees it as LUA.
anyway, have you just renamed it on the computer?
what i did was duplicate it AND rename it with full extension “xxxx.lua”
load it back and it worked. i’m on osx high sierra

yeah I tried to duplicate it and then rename (using win7) … but it did not work :frowning: