Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.3.x Firmware Workout: Better late than never



This might be a small graphic UI bug:

When I focus a control on the screen, then focus-press to open the oscilloscope view on that point and then press one of the M-Buttons under the expanded oscilloscope on the main screen until it is collapsed I can scroll through the controls and units again with the encoder but there is no indicator arrow on top of the controls until I press UP again.


Hmm – I’m not sure when this happened, but it seems like the sample slicing screen has lost quite a bit of zoom – you can only get so close, time-wise. Is this by design or something that’s going to change? I miss being able to get to very fine-grained levels.


I can get down to 7ms here.


How do you zoom on the slicing screen? I cannot find it.


Zoom on M4, hold it down and scroll.


Hm, M4 is “delete” here…maybe we talk about different slicing screens? I can find a zoom function one screen above the one where I can actually do slices - but the zoom factor is not taken to the screen where I actually slice the audio. What am I not getting here?


Ahh, sorry, you are right. I was one level up! That is indeed odd.

Edit: I also notice there when looking for a “hidden” zoom mechanism that when slice behaviour is set to cursor (in the bottom display) and shift is held the waveform is highlighted as if selected in scrolling. Is this related to an extant function or one coming?


you hold the fine/coarse button down and then turn the encoder. fine or coarse determines whether you’re zooming time or amplitude - i forget which is which.


Thanks @josker. I also found the answer to my own question above, select relates to the functions in the next level down in “menu”.


Great, thank you for clearing this up!


I just ran into the following problem:

I loaded a 200MB field recording into the sample player and everything worked fine so far. Then I tried to assign a different sample (125MB) to the same sample player but now I get a memory full error message. I deleted the old recording from the sample pool but it is still in the player where I don’t find how I could remove it before loading a new sample.

Any ideas about that?


Another thing I am struggling with:

I am pretty sure that in slice mode on the actual slicing screen it was possible to scroll around with the cursor and then jump with the playhead to that position by pressing S1, wasn’t it?

I am not getting that to work right now. Instead the sample always starts from the beginning and it is not possible anymore to audition the sample seeking for points in the audio and setting a slice there.

Or am I getting something wrong here?

EDIT: Okay, as a workaround I have to first insert two arbitrary slices, then jump around between those slices (S3 set to slices) and then switch S3 back to cursor. Now it is possible to jump to the cursor using S1 again. But you are not allowed to delete those two slices now unless you want to lose this function and have to start again…


I’m looking into this. :bowing_man:


I’m in the middle of a bunch of other firmware changes but for now here is a timely release to address some issues that users have been having in the last few days:

v0.3.07 CHANGES

  • ENHANCED: SD card file system improvements (speed and other things…:female_detective:). In order to get the advantages, from now on you should ALWAYS format your card with the ER-301 like this: Admin > Card Console > Format Card (S2).
  • FIXED: Slicing View > rewind(S1) was playing from the sample start rather than the cursor. (Hopefully, this works for you now @leverkusen)

Also, since I forgot to post them, here are the changes for v0.3.06:

v0.3.06 CHANGES

  • NEW UNIT: Slew Limiter, 3ms to 786s.
  • ENHANCED: -10V to 10V are now mapped to -1 to 1 (previously -10.24V to 10.24V was mapped to -1 to 1).
  • ENHANCED: Teletype support added.

New user: which firmware 0.2 or 0.3?

Indeed, it does work now - thanks a lot!


Will this move wipe all the files/samples from our SD cards?


@odevices, sorry but what exactly are we talking here ? … I’m lost on that change I don’t know to what it applies !



If I’m understanding it correctly, this applies to how external CV relates to modulating some internal parameters where the maximum value is 1.

Before you’d have to potentially do some math (or trial and error) when using units such as the Bump scanner.

Whereas now, if you ie: have the “center” parameter set to .5 and the modulation gain set to 1, the center parameter of .5 will be 5volts from an outside (or virtual inside) CV source. Setting a width of .1 would mean the bump scanner window would be between 4 and 6 volts.


@NeilParfitt Thanks !


What are the chancing of incorporating the bus protocol that Malekko uses in the Varigate 8+ and other modules? The protocol shares clocking, start/stop information, and preset saving using the bus.