Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.3.x Firmware Workout: Better late than never

feedback

#519

It is MIDI information. It’s the same protocol that macro machines and mungo uses to save and recall presets. Called the ‘select bus’ and data travels along the cv rails on the bus board. There is a document floating around somewhere.


#520

Do I need to do this to the supplied card to improve performance or does this just apply to new/other cards?


#521

Have the ER-301 since a month and it is running fine and stable on V0.3.x-unstable.
Very happy with this extremely flexible module.

I would very much appreciate if an “immediate” trigger custom control could be added to the units. The same as a trigger control but that fires if you hover push the button under it on the main screen. I thought as this feature request has already been made and that it has been taken up but I do not see it on the wiki, that is why I am enquiring as I may be mistaken.


#522

Got a weird bug on 3.08.

Added a custom unit and then sample player and VCA to it. Added an envelope to control the vca. Added various local controls. Weirdly the custom patch on track one is only playing out of track 4.

Another minor bug, a negative value on the sustain value (form the linear local control) causes the envelope sustain to behave weirdly.

EDIT : Rebooting and reloading the quick save has sorted it, now coming from track 1. Also tried creating a track with a sin osc and vca in a custom unit and it didn’t do the same thing, must be a very specific set of actions that caused this bug.

Feature request, perhaps some positive voltage only custom controls?


#523

Does anyone else find the new firmware (0.3) slower to use than the previous version?

I’m talking specifically about the way you navigate through units now, it seems like everything takes an extra button press and the display on the screen of a unit is taking up a lot of space now unless you click (again) to make it smaller.


#524

What exactly is taking an extra button press? It is still soft button to focus, turn encoder, press UP to unfocus.

You don’t need to use the contextual displays if you don’t want to. Just don’t focus press or press ENTER on a parameter.


#525

When I get time I’ll go back to 0.2 to check and then explain better what I mean.
With the units being bigger (contextual view), this didn’t happen in the older firmware, and I’m not sure if its my misuse but I’m not deliberately choosing it is happening accidentally as I go about using it.
Just as an overall perception, this version feels like it is taking longer to navigate than the previous one and its easier to get lost in levels of units than before.


#526

I always get into the contextual view by accident too when nearly automatically trying to unfocus a control by pressing the softbutton I pressed to focus it before.

Also the view often changes then and the same button formerly used to focus a control now gets a new function, e.g. on the sample player. When you automatically press it again you do something on the sample player like deleting slices.

Also when I am scrolling through a chain and altering things here and there I repeatedly change values instead of scrolling left or right because of this behaviour.

I think I find the new way less intuitive than it was before. I worked with it on a daily basis over 2 weeks now and it still continuosly breaks my flow and makes me feel unpleasant. Which is a shame because apart from that I really find the workflow very intuitive and was able to build nice patches just from having watched some tutorials last fall before ordering one.

I think pressing ENTER would be a great solution to get into contextual view and if I could vote I would vote for using the M buttons only to focus and unfocus. It is like opening a control versus just adjusting it and ENTER is a great button for for something like this.

Comparing to the ER-101/102 the graphic interface is very different and there are a lot more buttons - to me the focus press concept does not seem to be needed and useful here.


#527

In versions 0.2 and 0.3, focus press expands the parameter to its contextual view. The difference is that when you press the UP button (to unfocus the parameter), in v0.2 the contextual view is closed while in v0.3 it is left open. Also another difference is that in v0.2, both the soft button and pressing ENTER would focus a parameter. In v0.3, only the soft button focuses while the ENTER button will cycle through the different views of whatever is focused. Perhaps the last part is why you are accidentally opening the contextual view when expecting to focus it?


#528

Thanks for the explanation!
I’ll give it and try and see how I get on.


#529

Which “before” are you referring to? Probably not v0.2…perhaps you mean when I first introduced v0.3 and the soft buttons toggled between focused and unfocused?


#530

Question for everyone: Should contextual views be left open when you unfocus a parameter/control?


#531

Yes, probably - at least keeping the immediate focus/unfocus toggle seperate from switching through contextual views is what seems more practical to me.


#532

@odevices Just noticed a possible bug.
In the sample player I create my first slice, I then wanted to delete it but pressing delete doesn’t do anything - this is without moving the cursor.
I can go into then menu and clear the slice by ‘clearing all slices’ then go back and insert a slice and the delete doesn’t do anything everytime I do this.

Edit - strangely after trying this a few times it is now working!


#533

Which navigation mode (slices, cursor or follow) are you in?


#534

Whatever the default is as I haven’t changed it, I just created a mixer with a sample player in, added a sample and then went in and added a slice.
For the first three or four times the delete didn’t work but after that it did, just trying again now and it stopped working again then it started working again!
I just made a video on my phone and I tried to upload it but a message came up saying can’t upload so I’ll email it to you!


#535

I have experienced the same and just thought I just do not know how to do it properly - which slice has to be selected by the slice slider and where the cursor has to be…after a bit of uninformed trying it always worked in the end. Just without me learning why by now…:grin:


#536

@leverkusen and @sunshinelover

Does the following information help?

  • You are not required to placed the cursor exactly on a slice in order to delete it, since that would be impractical.
  • Here is the rule: When you press delete, the next slice after the cursor is removed.

Of course, that leaves us with an ambiguity. What if the cursor looks like it is right on the slice but (in actuality) due to limitations of the display resolution the precise cursor position is after the slice you are trying to delete. So make sure it is obviously BEFORE the slice and then press delete.

In the meantime, I will see if I can make it do something more intuitive in the case the cursor and a slice fall inside the same pixel width.


#537

Got the video. Thank you very much!


#538

Hope it helps. This is with the latest firmware and running at 48K