Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.3.x Firmware Workout: Better late than never

feedback

#1103

Darn it! Looking into these. :bowing_man:


#1104

I can confirm this one!


#1105

Sorry for the wait. These both turned out to be head-scratchers. :dizzy_face:

v0.3.25 CHANGES

  • FIXED: All delay units > Feedback parameter turns to NaN when dialed all the way up on 48kHz firmware only. The delay unit stops producing audio once this happens.
  • FIXED: Global Chains > Right channel of stereo global chains were not being restored properly from presets and quicksaves.

#1106

Hello! First I want to sat that this 0.3 versio is really cool! Super cool features…

But I have problems when I am trying to save chains.

FIRST: I did channel chain (with samplers etc.) and saved it in the card (filename 1+2.lua) and everything went fine.
BUT THEN: I did another similar channel chain (it was for channel 4) and saved it (filename 4.lua) BUT now when I am trying to load the chain 301 says that .LUA is not valid extension?? So why the extension is .LUA and not .lua?

Is there some problem in the firmware or what I am doing wrong?

Also I cannot load any of the old chains (–> same error message)

it is same in both versions 0.3.24/0.3.25 (48kHz version)


#1107

On the download page I took the time to read through the list of fixes, enhancements, and new units distributed across the 26 updates in this 0.3 cycle and am astonished that this was all accomplished over the previous six months.

This incredible opportunity to watch and influence the evolution of a module I think is unique in the history of Eurorack, add to it that the development, manufacturing, customer service, and coding is all done by one person and I can’t help but be moved to astonishment.

I’d guess that within the next two to four weeks we’ll see the first iteration in the v0.4 cycle at which point the delirium of novelty may push me to a kind of innovation drunkenness.

Thanks Brian for this Herculean effort.


#1108

Are you saying that your filenames were:

  • filename 1+2.lua
  • filename 4.lua

or

  • 1+2.lua
  • 4.lua

May I have an example of one of your old chains please? Also, the above files while you are at it.


#1109

You are VERY welcome. Although there are times when I would love to redirect a river through my workshop. :laughing:


#1110

i solved the .LUA vs .lua problem just copying the .LUA to my computer, duplicating it, renaming it and loading it back into the sd card. it did the trick.


#1111

Here is link to a folder where those files are…
https://drive.google.com/open?id=1ftBpCWSinUAm7ujM35O5HAHpAJTkIKgs
1+2 is working but 4 and 04 does not

and if this helps:
CHANNELS 1 & 2 are linked
Channels 3 & 4 are mono channels…

/////////////////////////////////////////////////////////////////////
And example of old chain which is not working is: 0001_2

//////////////////////////////////////////////////////////////////////

In this image you can see those crazy extensions ???


#1112

I tried this but it did not help… Also in my computer the file extensions are .lua only 301 shows them .LUA ??


#1113

yes, same thing here. only the 301 sees it as LUA.
anyway, have you just renamed it on the computer?
what i did was duplicate it AND rename it with full extension “xxxx.lua”
load it back and it worked. i’m on osx high sierra


#1114

yeah I tried to duplicate it and then rename (using win7) … but it did not work :frowning:


#1115

So I tried loading your chain presets and mysteriously they all worked, and, no weird extensions:

0005

I’m wondering if it is due to file system incompatibilities. Please try this:

  1. Back up the contents of your uSD card to your PC.
  2. Reformat it with the ER-301 > admin > Card Console > Format Card command.
  3. Copy your files back to your freshly formatted card.
  4. Test again.

#1116

@odevices – I’m sure this is not a simple question to answer, but I was just wondering: Are we expecting much changes in future firmwares that will break custom units? I’ve been holding off on building, well, building blocks like pre-setup samplers, drum synths etc., but was wondering if the time would be ripe to start accumulating stuff in my ER-301 closet. :slight_smile:

Thank you!


#1117

There is definitely a good chance that some of planned changes in v0.4 will break (or at lest make obsolete) certain custom units made with v0.3.


#1118

Thanks for the quick reply!


#1119

trying to install the 0.3.25 update but when switching to Admin, the screen shows a growing bar (right to left) in the Kernel Memory Box. I cannot scroll to the Firmware update screen…
Probably I am missing something silly
Any idea?
Thanks


#1120

That sounds weird - did you see the wiki page on updating the firmware?

http://wiki.orthogonaldevices.com/index.php/ER-301/Update_Firmware

edit: oh wait, are you sure you are in the admin section and not in the memory usage screen?


#1121

Please move the MODE switch to ‘edit’.


#1122

damn I was in scope mode…
my mistake (as expected).
But hey I am only starting to use the ER-301 today! so I am a noob with this
Thank you! @kel and @odevices