Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.4.x Firmware Workout: Goofing off never felt this hard

feedback

#208

Your samples should all be restored. May I have more details so I can try reproducing the problem?


#209

Weird it appears that I cannot recreate the issue and it happened once. Sorry for any confusion, I will let you know if it happens again.

All of my varispeed players on one track were the issue where the samples weren’t linked but today when I loaded up the same quicksave to recreate the issue they were all working again.


#210

hard freezes on 0.4. i’m able to reproduce them. in about a couple of hours i’ll post the quicksave and notes about how to freeze. it involves buffers, the problem arises when 1)clicking on INS to assign or change an input, 2)recalling the Quicksave window (this is more random, less predictable).


#211

here it is @odevices:
Q01.save (55.7 KB)

i just tried again, i load it up, it loads and works fine but as soon as i reach for an IN port, it freezes. no way to awake it other than power cycle.
thanks for your support :slight_smile: this is the new setup for my work with the band (Hollow Bone, a trio, guitar, drums and modular synth.


#212

What do you mean by this? I tried loading your quicksave and then assigned an external input to the source of the OUT1+OUT2 chain but I got no freezes.


#213

as soon as i go to the inputs of chain OUT 1 & 2 and click the M2 button or the M3 button below them i get a freeze. BUT please try the following, because i forgot to un-bypass the loopa! unit which contains a looper and player sharing the buffer. now the inputs work.
please try to unbypass the LOOPA! and save the quicksave, now try to click on the inputs. it freezes for me. but with the LOOPA! un bypassed at quicksave init. i can reproduce it every time.


#214

ah sorry, another thing. un-bypass the loopa! , save the quicksave then power cycle or reboot. load the quicksave and go to the inputs for this to happen 100% of the times.


#215

Darn. Still no freezing. I wonder if I need to have your samples? :thinking: How much memory is free in the Sample Pool?


#216

free: 229 mb.
one thing: it always asks me what i want to do with unsaved buffers prior to saving the quicksave, i always do “continue with quicksave” and don’t bother.

do you want a zipped folder with my samples?


#217

anyway i don’t know if it has to do with samples because in this setup i start with this situation, then i swap mixer channel presets (containing long samples) when i go from one song to another (i have some pre-prepared textures and layers for almost each song). so this freeze happens with everyone of them.

very strange, now i got a freeze even with loopa! bypassed at loadup. i thought i might have a temporary solution…

can i try saving to another slot? will it matter?


#218

Since I have no idea what it could be, I think the best way forward is to send me the required samples(*) so that I can reproduce your quicksave exactly. I appreciate your help with this! :bowing_man:

* Make sure to include the slice files (*.slc) too.


#219

here they are:


#220

Thank you for the files, @hyena. Although, sequoiaverb.wav is in use, I don’t see the STATNOISE.wav being used anywhere in the quicksave you provided. May I have confirmation that I’m working with the same quicksave file that you are?

Also, may I have you zip up your ER-301/v0.4 folder and send it to me please? Perhaps having your meta-data is key to reproducing this crash.


#221

Of course,i’ll send it over asap :slight_smile:


#222

i forgot to mention the preamp settings! i think they might be involved and iirc they aren’t saved in the quicksave, or are they @odevices?
my settings are:
IN1:4x
IN2:4x
IN3:2x
IN4:4x


#223

They are saved and restored with quicksaves. Why do you think they might be involved?


#224

another thing: you mentioned that you don’t see the STATNOISE.wav file being used, but i clearly see it, in the submixer channel besides “sequoia”, its used by a sample player! i might have sent you the wrong quicksave? anyway, here’s the link to the whole 0.4 folder:


#225

In the quicksave that you gave me that particular sample player is not attached to any sample and STATNOISE.wav is not loaded into the Sample Pool. In fact, you can do a text search of the data in the Q01.save file you linked above and confirm that STATNOISE.wav is not referred to anywhere.

Which slot is the quicksave in question? Slot 13?


#226

exactly, slot 13 HB2018


#227

Unfortunately, still no crashes when loading slot 13 and assigning inputs. :cry: When you say it is reproducible, do you mean you can turn on your modular right now and get it to crash? Or was that during one (potentially long) session?