Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.4.x Firmware Workout: Goofing off never felt this hard

feedback

#550

HURRAY!

ok… now, how to push that deadline further into the week…


#551

fantastic! i’m trying my loopa! units.
they load up perfectly but some of the internal routings are messed up, if i try to re-establish them as locals they don’t work. probably because it was built around custom units custom controls and not the locals system we have now.
have to investigate further.
thanks for this great update Brian!


#552

If you can identify a specific failure that would help. :bowing_man:


#553

will try! but as said i think it has more to do with how controls were mapped.
example: i had inputs on the custom unit for gate and clock that were assigned to multiple destinations. the routing is lost and if i try to re-assign i can only do that to the physical input already assigned to those controls (example: i have a custom control for “GATE” , i have a pedal looper that is recording that GATE. the routing is lost. i try to route back to that custom control, it says “no signal”, if i assign that input to, say, G1, then go to the pedal looper and try to assign, i can only assign to the G1 i see below the “GATE” custom control). i attach the kicka! custom unit as example:
kicka3.unit (19.1 KB)


#554

Hmm, I’m comparing between loading this unit in v0.3.25 and loading it in v0.4.09 and I still don’t see any differences…

For example, here the Custom Unit’s Gate control is properly mapped in both cases:

In v0.3.25
0012
In v0.4.09
0037


#555

Also, if I pretend there was no assignment, and create it myself, I do not have this problem. I can select the kicka! > Gate control as well as the G1:

Selecting kicka! > Gate
0038

Selecting G1
0039


Units that block their inputs
#556

hmmm, this is strange, but if you remember i already had this intermittent problems, now and then.
wonder if there might be something messed up in my sd card?
is that possible?
otherwise i’m doing something wrong but i don’t see where!


#557

Is it something that breaks only in stereo? What happens if you try your preset in a mono chain?


#558

aaaah! good idea! i’ll check later when i go back to my system! thanks!
pretty sure i tried in stereo!


#559

Cheers on 0.4.09, Brian! Looking forward to checking it out - great stuff here!

I’ve had zero time for music stuff for the last month or so, but hoping that will change in the next week or two, and I’ll plan on doing some maintenance work on my bespoke library.


#560

Just trying out the new scope function and I love it. Any chance it will find it’s way to global chains? I usually have all of my sources in globals so I can call upon them anywhere in the 301 so it’d be amazing to have the new scope function available up there.

Also
" Track|Sample & Hold > Was not saving and restoring its last held value from presets."

I would have thought this would allow for voltages within the voltage bank to be recalled with presets which it doesn’t seem to be doing for me. Is this incorrect thinking or am I just doing something wrong?


#561

There is a good chance. :wink:

Oops! It looks like you are right. I fixed it and then broke it again. Sorry!


#562

Awesome! I’m cheering without any implied pressure, Joe :laughing:


#563

Hi, i was running 3.25 and just upgraded to 4.09. I had a bunch of quicksaves on the card (i had made these in v2 firmware) and read that saves from 3.25 should load into 4.09
But I keep get ‘quicksave are incompatible with this version’ error when I try and load them…

Checking the card there are three folders where files live ‘sc’, ‘v0.3’ and ‘v0.4’
is ‘sc’ the old pre v3 filrmare spot?
How can I get my old preset to work under 4? do I need to reload firmware 3.25 and upgrade them to v3 before then using them in 4?

thanks! :slight_smile:


#564

Yeah no pressure at all Joe :rofl:
0004

Mind you it’s really easy to change the library names even for ordinary users like me…

So happy about the 0.3 compatibility @odevices! That must have been a tough nut to crack :dizzy_face:


#565

Thanks for the screenie. I have not had any time to spend with my modular for a few weeks. That definitely needs a tweak! Hoping to get a little time this weekend. :slight_smile:


#566

What version is shown in the quicksave slot that is failing to load? It has to say v0.3.25 or higher. For example, if you have a v0.3.18 quicksave then you have to re-save it in v0.3.25 first.

Then you will have to copy the Q01.lua files from the v0.3/quicksaves/slotN folders to v0.4/quicksaves/slotN folders and also change the extension to Q01.save.

Oh and if you want the slot names to be propagated then you will need to copy over the v0.3/quicksaves/names.lua file. Do not change its extension though.


#567

Had a little issue last night I was wondering about… The LED on channel one wouldn’t stop blinking erratically? I think what happened is I went to load a sample into the pool and channel one started blinking as I was auditioning sounds but it got stuck and just kept blinking. The weird part is that the frequency seemed to be changing randomly. I rebooted and it stopped but if I repeated the action I got the same result. Thoughts?


#568

Maybe the channel was muted… it blinks then…but i don’t think the blink should change frequency. Unmute the channel with shift+channelbutton.
I had a somewhat similiar issue today… i switched the sample preview from channel 1 to 3+4. All good…loaded a sample into a sampleplayer on 3+4. Channel 1 was muted (blinking away), i unmuted it but discovered later that it still wouldn’t output anything… hat to restart.


#569

Would it be possible to save the “focus state” within a quicksave ? When it loads, it always displays the top level.