Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.4.x Firmware Workout: Goofing off never felt this hard



You are absolutely right! Sorry about that :bowing_man:

v0.4.11 CHANGES

  • FIXED: Sample & Hold > Mono version was failing to load.
  • ENHANCED: Grain Stretch > Jitter control is now modulate-able.


Bug report, observed in 0.4.08 and 0.4.11: “trigger on fall” method for Gate controls does not work as expected.

To reproduce: Create a custom unit with one Gate-type control. Set it to “trigger on fall”. Connect it up to a gate signal and observe the output. (note that I’ve also seen this on Gate inputs of builtins, namely the Raw Player, so it’s not strictly a custom unit thing)

What I expected: the gate indicator and would flash and a trigger would be output when the input signal went from high (greater than some threshold, say 3v to be safe) to zero or below.

What I observed: No indicator or output trigger for any high, low, or transitioning input. Usually one trigger is output when I save the input settings and then no more after that.

With the same configuration, setting the Gate input to “trigger on rise” behaves as expected when the gate signal goes from low to high.

My gate signal was a manual pushbutton from a Doepfer A-164-1 into input A2 of the ER-301.


Confirmed and thank you. Looks like only the manual fire (S3) button is working as expected. Sorry about that.


I’m a little late to the v0.4 party, I’m running v0.4.10. I have two mixers in series in a stereo chain. When I look to take outputs inside the first as inputs into a unit in the second, I can only find the left. How do I find two parts of a stereo pair with the new scope mode?


It just depends on which channel (OUT1-4) is focused.


For example, suppose you have OUT1 and OUT2 linked. Then to select the right side, you would have OUT2 focused when you are making your selection in the scope view.


Ah perfect thank you!


Hi @odevices,

I seem to have a weird bug in my er-301. Running 0.4.10.

When loading a quicksave that contains units on channel 3 and 4 (configured as either mono or stereo) the red lights blink fast and no audio comes out. Linking and unlinking 3/4 solves this but obviously that gets rid of all units on ch4.

Here’s a youtube link: Funky lights, no sound

Hope you recognize it and that it’s a software thing.

Thanks! Cheers, Harmen


It seems ch 4 is muted. Unmute with shift+ch button. Still weird this is happening when loading a quicksave…does it happen on other configurations too?


oke, I decided to give the new firmware a spin and I am sorry I didn’t read thru the whole thread but as I insert a sampleplayer, doesn’t matter what sample player, the sound I put in (a kick this time) it triggers by itself. Did I miss something? So I don’t have anything in the gate input… I have it on all channels (2x stereo)


I agree with this. Mute state was recently added to quicksaves so probably this is a bug related to that.

Sample Players now initialize with Play Duration set to ‘repeat’ and Play Extent set to ‘all’. These are options that are set in the unit’s menu.


Awesome thanks, that was indeed it. Sorry for the silliness.


Awesome @elias and Brian @odevices. I’m reasonably acquainted with the unit but finding a ‘new’ feature (didnt know there was mute functionality) when you think it was a bug is nice. :blush::+1:t2:


I’ve also noticed channel 4 being muted after loading quicksaves. I just assumed that I had muted the track before saving, but perhaps not?


Has happened to me too.


This behavior was seen after I loaded @Joe’s most recent guitar grid quicksave. I tried resaving it with chennel 4 unmuted, but still it comes up muted.


Is there any chance we could have an option to change this initialisation behaviour (in Global Audio settings in Admin for example)? I am yet to have a scenario where I use those particular settings.


This is a requested feature already which will be achieved via having you set default unit presets.


I’ve noticed the channel 4 being muted bug when loading quicksaves as well.


Same here too


That is more than enough “me too” posts, guys. :laughing: