V0.4.x Firmware Workout: Goofing off never felt this hard

v0.4.15 CHANGES

  • FIXED: Unit Header > Swapped ‘Replace’ and ‘Config’ commands so that the more often used ‘Config’ command does not require a SHIFT press.
  • FIXED: Unit Controls > ZERO (SHIFT+HOME) was not working.
  • FIXED: Unit Menu > Reinstated access via focus press on a unit header. This means there are 3 ways to access the unit menu: (1) Focus press the header, (2) long press the header and choose ‘config’, and (3) focus the header and press S3.
  • FIXED: Hold Mode > Pressing ZERO on a Master Fader would sometimes not work.
  • FIXED: Hold Mode > Pinned Control > Unpin command was leaving a ‘ghost’ control behind.
  • ENHANCED: Hold Mode > Pressing COMMIT on a Master Fader will immediately set it to 100%.
9 Likes

Yes, I changed nothing to the external signal, and switched firmwares to check. I will try and reproduce this in a slimmed down testing environment and report back.

The crash happened super fast and on several occasions. Never had this sort of crash on the previous firmware!

I can definitely follow the reasoning and I think you are right, but yes it is an obvious feature request. I guess there is no real difference between assigning an internal or external signal to the Master Fader control, UI-wise? Somehow I could imagine being able to only assign external signals to the Master Faders and avoid getting into subchain territory in Hold mode. It’s a difficult one.

Thanks! :star_struck:

Of course
I try on varispeed and raw player
In slice view mode hold on button under the waveform view then open editor
That do nothing…
I must go to config then slice buffer to have the slice view and sample editor…

1 Like

whoaaaaah!!!
i’m starting experimenting with the hold mode paradigm from 04.15 directly as yesterday i was working then slept about 16 hours :smiley: i think i even dreamt about the 301 eheheh
i can’t even begin to say how great this new mode is! brain is melting for the thought of how many crazy ways of altering a live performance we have now! it reminds me of two things:
1)the xfader on the octatrack
2)the controls on the great INA\GRM plugins!
the ability to switch instantly to a set of param values or to morph smoothly towards them is great!

internal or external cv control of master faders seems an important feature to me too. the possibility of sequencing master faders gestures is :open_mouth:
but then a doubt arises: what if one is modulating two different master faders contemporarily and they both control partially or totally the same parameters?

question: is there a maximum of different pinsets we can create? if so, what’s the number?

Brian, thank you for constantly expanding this little universe! firmware isn’t even half way to a 1.0 release and it’s already perhaps the most advanced single piece of electronic music gear ever!

6 Likes

You are very welcome! :bowing_man:

There is no problem even if PinSets overlap because a Master Fader disengages all other Master Faders while you are manipulating it.

There is no maximum enforced in the software.

3 Likes

Had my first play with hold mode this morning. Top work, @odevices, thank you!

A couple of functions I thought make nice enhancements.

When you long press a control that is already part of one or more pinsets, you get the option to unpin it from any existing pinsets. Might be nice if you also had an option to update a given pinset that the control is present in to the current edit mode value. (Edit: I guess you can already sort of do this by an un- and re-pin combo, though it moves the control).

To further that a little more, might be nice to have a function to update a given pinset so that all controls in it get set to the current edit mode values. Possibly a config mode function?

3 Likes

This looks amazing. Thank you @odevices!
It’s insane to catch up to the thread and see how fast you fix bugs. :mage:t2:‍♂:man_artist:t2:

1 Like

BUG: When going to save a custom effect that has a custom name, it seems to rename the unit (not the file) to Custom Effect. This seems to happen when you click save, before you commit.

Also, pinsets do not seem to save with the preset? Is that expected?

Which preset? PinSets are a considered a property of the top-level output chains (i.e. OUT1, OUT2 etc.). They are not owned by units. This means that PinSets are only saved as part of a top-level chain preset or as part of a quicksave.

The name is not actually changing. It has always been that if you focus a unit header and press SHIFT, it will show you the unit type.

1 Like

Ah, that explains it I guess. I had a preset from the previous firmware (0.4.11). It was a custom unit (which Iooks like is now a custom effect). I added some PinSets and re-saved it, rebooted (rather quickly I might add :slight_smile: ) and the PinSets were gone.

Makes sense I guess. This way the PinSets can cross units.

This is confusing me. A pinned control always follow the value of the control in edit mode. Is this not happening?

Oh wait. I get what you mean now. You want a command that snaps the target to the current value. Language problems. :crazy_face:

Exactly. Practical use case. Let’s say I’ve built a little synth and have PinSets A and B with the same controls at different values, allowing me to snap back and forth between two distinct timbres.

I decide I want to make some changes to the timbre in PinSet B. I might want to do that by snapping to PinSet B (in hold mode), and then switch back to edit mode so I can hear the effect of the adjustments in real time, without having to hit Enter to commit each time.

Once I find the value I want, it would be nice to just update PinSet B’s control with the new value that I’ve settled on in edit mode.

Or even better, if I’m making adjustments to several controls, going back and forth dialing the new timbre in, it would be nice to be able to do a bulk commit of all controls present in PinSet B to their current values in edit mode.

1 Like

I had to move some menu items around in Hold Mode. The ‘Unpin All’ and ‘Clone’ PinSet commands are accessible via a long press on a Master Fader.

v0.4.16 CHANGES

  • FIXED: Hold Mode > Sub menu zombies when using any command that removes pinned controls or PinSets.
  • ENHANCED: Hold Mode > Added ‘Reset Targets’ command to PinSets and ‘Reset Target’ command to pinned faders. Resetting a target means to move the target value to the current value of the control.
6 Likes

Hi,
I have just updated to firmware v0.4.13. It has been a while since I last used the module so I am a little confused. How do I load a file into the variable speed player? I can’t seem to be able to get to the special menu to load files ( used to be a button press under the header section of player - I think).
Thanks

This is fixed in v0.4.15. I ran into the same exact issue yesterday :slight_smile: but I learned there’s a bunch of ways to do that now.

  • FIXED: Unit Menu > Reinstated access via focus press on a unit header. This means there are 3 ways to access the unit menu: (1) Focus press the header, (2) long press the header and choose ‘config’, and (3) focus the header and press S3.

:slight_smile: OMG, just tried it out, and it is awesome. Thank you!!!

2 Likes

Quicksave (.save file) from v0.4.11 is consistently causing a crash. Are they meant to be compatible with new firmware?

Yes. Did the crash come with a log?

crash.zip (545 Bytes)

1 Like