Home | ER-101 | ER-102 | ER-301 | Wiki | Contact

V0.4.x Firmware Workout: Goofing off never felt this hard

feedback

#148

Keep in mind that these early firmware releases are a testing playground. If you’re using the module for critical stuff, stick with .3 until the new features are deployed and rigorously tested.

There should be no pressure on Brian to quickly rollout features that are temporarily removed.


#149

I agree, but I wouldn’t consider a question like “Would it be possible to give us a rough estimate…?” as putting pressure on Brian. My impression is that a lot of us are in the “the grass is always greener on the other fw” state right now, so all I wanted to find out was if custom unit controls in 0.4.x are maybe just around the corner or not. Brian is free to say “no, I can’t” or to not answer at all (which is fine) – so I think this is a valid question.


#150

I only tested this in latest v3.x but it seems I cant copy/paste something from one global chain to another


#151

if there is a bug in the current stable firmware, you might want to report it in that firmware’s thread. This thread is just about the v0.4.x beta firmware. :slight_smile:


#152

of cause, sorry.! I didnt see it fixed in the v4.x notes, so thought i might put it here aswell, but i wont do that again.


#153

Please don’t get too excited yet :bowing_man: Custom Units are still not re-enabled! In this release, I have completed a LOT of low-level changes which were needed in preparation for the updated Custom Units. Now, while I go ahead and work on the high-level changes, it would be great if you could do me a favor and put this firmware through its paces and help identify any problems.

v0.4.02 CHANGES

  • FIXED: Memory leaks when loading quicksaves and certain types of units. (This should improve stability!)
  • FIXED: Channel Mute > Garbage in the audio buffers was causing audible noise.
  • FIXED: Channel Mute > Flashing LEDs were not synced and channel selection was hard to see.
  • FIXED: Teletype > Removed old i2c addresses and set the default i2c address to 0x31 as required by Teletype v3.0.0 and above.
  • FIXED: Admin > Renamed Load screen to CPU Load.
  • FIXED: Middle Layer > Enabled compilation of units with internal feedback loops.
  • ENHANCED: Channel Setup > Moved out of the admin area and is completely accomplished in the user area by just chording the two channels that you want to link or unlink.

#154

I just tried this (in v0.4.02) and it works as far as I can tell…


#155

A week?

I’m probably jinxed now. :fearful:


#156

Love it - much more convenient! It would be great if one day this operation could automatically do some kind of temporary chain save and reload of the chain that was in place when going from M->S or S->M. Low priority stuff in the grand scheme of things since it’s easy enough to do manually. But would be slick nonetheless. :slight_smile:


#157

A week would be awesome! No pressure though. :wink:


#158

@odevices
Whoooo this 0.4 announcing Some good things
Thank you for all !
But now I want a second 301!


#159

Maybe I missed it? But is this where the Custom Controls get ranges that adapt properly to the parameter they’re mapped to - i.e. ADSR control etc

i.e. Custom controls for ADSR? - how are people managing them


#160

POSSIBLE BUG (0.4.0.2):
-i had quicksave slot 1 occupied by a quicksave (named Test)
-i made a patch with some mixer channels with varispeed players in them
-went to quicksave
-saved to the first slot
-renamed the slot
-reloaded without leaving quicksave menu
-it seems to load but then the patch is empty

looking at the display it shows (quickly) loading “xxx unit” (and they are the units i saved in the new quicksave) but then sometimes ends with “removing units”.
i rebooted and tried again. same thing.

is there a way to textually edit the quicksave in order to remove the “removing units” part?

here’s the save file:
Q01.save (20.9 KB)

EDIT 1:i can reproduce it , at least on Slot 1, now i will try on the other slots as well. the saved quicksaves are not loaded up correctly.
this time i saved the chain as well (i was working with a single stereo chain) and that loads up quite fine.

EDIT 2:i can reproduce it also on other slots previously occupied by other quicksaves.

EDIT 3:i can reproduce it even on fresh, Empty Slots. but older 0.3 quicksaves which i copied to the 0.4 folder (changing extensions) load up just fine.

EDIT 4:experienced a full freeze with no crash log, had to power cycle.
one chain, channels 1&2 stereo linked, 3 mixer channels each with a varispeed player, one with additional vca and adsr.
i went into the first mixer to assign ext input to v\oct of varispeed player, as soon as i clicked the contextual button to assign to v\oct it froze.
power cycled, reloaded chain, assigned v\oct ext input with no problem.


#161

Next question - Custom Unit controls be CV assignable?


#162

This happened to me yesterday just before a show, opening for Squarepusher! :fearful:

After some alterations on the patch during soundcheck I saved it(luckily) on another quicksave slot and turned off the modular. When I turned it on again during pre-show linecheck the quicksave loaded but it was empty. I had to load the original quicksave slot and do the alterations by memory on the fly. Ufff. Fortunately everything went well.

Just wanted to share this with you. :slight_smile:


#163

Oh my god. :grimacing::grimacing::grimacing: Glad it went well in the end!


#164

0.4.2 -Looks like level meters on the mixers are not working.


#165

Something similar to the quick save reports above: 0.4.02 48k, made a quick save and it loaded only app. 50% of the patch, the rest was missing.


#166

Similar report here - 4.02/48. I performed a quicksave to an empty slot.

On reloading it, Ch3’s units were loaded into Ch1… and the save’s Ch1/2’s stereo chain was nowhere to be found.


#167

Thanks everyone for the bug reports. I wonder what is wrong with the quicksaves :thinking:.

I spent the weekend riding my bicycle from Tokyo to Mt Fuji and then participated in a sportive that was being held there. I’ll be back at the keyboard tomorrow. :biking_man: