V0.6.x Release Candidate: Packages and Mods

Not sure if this is a bug: if I have a simple chain with vari-speed player followed by freeverb, replacement of the the sample in the vari-speed player results in no sound out of the freeverb unless it is bypassed or replaced (with a new freeverb). Freeverb settings are size: 0.72, damp 0.5, width 1, wet 0.65.

vari-speed player config: play duration: once, play extent: slice, slice polarity: symmetric, cv-to-slice: index

2 Likes

I tried to create a package from a unit but it wouldn’t show up in the file browser :thinking: Has something like this been reported before? Steps I took:

  1. Build the unit in the UI
  2. Save a preset from the finished unit in my preset folders
  3. Switch to Admin, go to Packages menu
  4. Hit “create package”, look for the unit and not find it

My other .unit files are there though (as far as I can tell). Some more things I tried:

  • Try again from a restart
  • Rename the unit
  • Save the unit in a different folder

All attempts to find the unit from the file browser in the package manager failed.

I would just save the unit to the package folder to start with. Then create the package from there. You don’t have to do it that way but I do it so everything is in 1 place and easier to find / track later.

Also check this for step by step

1 Like

Cool! I saved it in the package folder as you suggested and I there it actually did show up, magically. I see no logic behind it, but it works so, alright.

I think I will need more details because the procedure you followed has been shown to work.

What did you name your unit preset file? Does the unit preset file exist when you check on your PC? Does it have the *.unit extension?

Yes, the file was supposed to be there, I mean it was there on my PC. As the matter of fact I shared it in another thread for someone asking for a solution here Request: Flip Stereo Output - #2 by Bparticle indeed, with *.unit extension. It works as expected and loaded well as a preset, only I couldn’t see it in the preset folders from the package menu, until I saved it in the packages folder as suggested by mudlogger.

Are you on v0.6.11?

Regardless, I completely failed to reproduce this on v0.6.14 and v0.6.11. :sob: Here are my steps that are designed to follow as closely as possible what I think you did based on examining flipper.unit:

  1. Create a Custom Effect unit
  2. Save Preset
  3. Navigate to ER-301/v0.6/presets/custom-unit
  4. Create a New Folder called Utility
  5. Navigate to Utility
  6. Press New File and name the preset as flipper.unit.
  7. Press ENTER and the preset is saved.
  8. Switch over to admin and enter the Package Manager
  9. Press Create Package (the sub display now instructs me to Choose Presets)
  10. Navigate to ER-301/v0.6/presets/custom-unit/Utility
  11. Select flipper.unit (yes, it is showing) and press ENTER
  12. Next I need to select the package filename and destination (I chose ER-301/packages/flipper.pkg)
  13. Next I need to specify the author.
  14. Done.

Do you see anything that you did differently that could be suspicious or a good place to start looking for the bug?

Maintenance release v0.6.15 is now available.

Release v0.6.15 · odevices/er-301 · GitHub

  • FIX: Unit Chooser > Make alphabetic ordering case-insensitive.
  • FIX: Hold Mode > Pinned controls not restoring with chain presets. Issue #41
  • FIX: Installed packages not available if front card not mounted Issue #42
  • FIX: Packaged presets not loading sample chains in certain situations Issue #44
15 Likes

Sweet, thanks for these @odevices ! Some really nice improvements here. :star_struck:

1 Like

Save from what I had for breakfast that day, it’s pretty much spot on! I can’t see anything different, very strange. I will check firmware later today and have another look if I can reproduce it again myself.

1 Like

Thanks Brian :slight_smile:

1 Like

Hmm… I was about to finally take the plunge to v6, but when I try to update from the latest zip (0.6.15), it says “Failed to open zip file.”

I’m updating from 0.5.03… is there any special steps I missed?

UPDATE: ok… i had copied the zip file from my iPad and when i mounted the sd card on my mac, it didn’t have a .zip extension visible but the operating system still had it as a .zip filetype :man_shrugging:

@odevices definitely a confusing thing on the part of iPadOS Files.app, but perhaps this is an edge case to consider supporting?

I suppose the thing to do is to stop using the *.zip extension for the firmware archive. I wonder what is a good alternative extension…ideas anyone?

Some ideas:

*.fw
*.fzip
*.firmware

Monome Norns uses .tgz for compression if that’s any use.

tbh - I don’t use an iOS device to transfer and or save anything especially firmware.
Just don’t use an iOS device to update the firmware. Use a computer.
After all, you have to put the firmware on a mini usb anyway via a computer.
Try downloading an album from bandcamp or code from GitHub on an iOS device - you can’t.
On GitHub - code → download zip on iOS is disabled.

The most elegant way i have seen for firmware updates is with monome norns with built in wifi - its all automatic, but the er301 doesn’t have wifi.

.301 ?

2 Likes

Sounds like an iOS bug, zip should be perfectly fine

1 Like

I checked again and found out what happened. I had navigated to the 0.5 folder from the package manager, that has the exact same folder structure as 0.6 of course, except for the new units that I’m adding. False alarm, user error, no bug! Sorry for the time wasted :flushed:

1 Like

No prob :blush: Thanks for double checking for me.

Depends which iOS device you’re using, I think. On an iPad Pro from the past year or so, you can download a zip file of the code from github. There are also some pretty nifty usb-c hub devices that attach to the side of the iPad to connect USB thumb drives, SD and micro cards, etc. and you can transfer from the Files app onto them without a computer middleman.

I’m not sure how fringe this use case is at this point. The line between my iPad with a keyboard accessory and laptop is getting more and more blurry. Heck, I can code norns scripts using only my iPad. :wink:

That said I’m not really sure what went wrong here with the .zip extension. Seems like it should just work?

EDIT: Actually I just tested the process end to end and updated to 0.6.15 using only the iPad to download the file from github and transfer to SD. It worked fine. So maybe the issue is in the transfer to the Mac?

1 Like

*.301 ?

4 Likes